Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004455TestLinkChartspublic2011-05-05 08:222011-07-02 13:49
Reportergbonney 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version2.6.31.5-0.1
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004455: Misspelled variable in polarion integration causing charts generation error
DescriptionWe've created a new project in 1.9.1 an upgraded to 1.9.2.

The chart.php just shows "Wrong ID" in 1.9.2. This could be a migration problem?
TagsNo tags attached.
Database (MySQL,Postgres,etc)1.4
BrowserFirefox
PHP Version5.3.0
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon screenshots.zip [^] (142,657 bytes) 2011-05-05 08:22

- Relationships
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0014796)
Julian (reporter)
2011-05-05 08:42

Issue is absolutely not clear.

The problem might be everything from your description.
(0014797)
gbonney (reporter)
2011-05-05 09:08

by clicking on the charts link on the "Test reports and Metrics" page, the chart doens't come up. it just shows "Wrong ID".

Have you seen the attached screenshots?
(0014798)
Julian (reporter)
2011-05-05 09:28

Of course but i did not watch you migrating the database as you asked if this might be the reason.

I cannot reproduce this issue. Which database do you use? We need MySQL, MSSQL, Postgres information here.
(0014799)
fman (administrator)
2011-05-05 10:30

Just to complete Julian comments:
we want detailed steps to reproduce in addition to screen shoots.
We do not accept screen shoots as alternative to detailed steps to reproduce (AKA test case).
Without requsted information we will be forced to close issue with 'Unable to reproduce'.
(0014840)
gbonney (reporter)
2011-05-12 10:02
edited on: 2011-05-12 10:35

I found a solution for this Bug!
My submitted int_polarion.php got changed within your review.
The is a simple Fix:
change Line 73:
from: $tmp_id_Len = strlen($tmp_id);
to: $tmp_id_len = strlen($tmp_id);
_________________________________________________________
        private function convertWorkItemIdToSvnPath($id)
        {
                $id_len = strlen($id);
                $path = '';
                $workPackageId = split("-",$id);
                $tmp_id = $workPackageId[1];
                $tmp_id_len = strlen($tmp_id);
                
                switch ($tmp_id_len)

(0014841)
gbonney (reporter)
2011-05-12 10:45

Please correct the misspelled variable and close this issue.
(0014842)
Julian (reporter)
2011-05-12 11:05

Fixed variable name:

Branch 1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/5835bbc531dcef3db5768d6165df170baf94afa2 [^]

Master:
http://gitorious.org/testlink-ga/testlink-code/commit/ada65dff3097f989a11d03e82591b69ab161d072 [^]
(0014843)
Julian (reporter)
2011-05-12 11:05

Thanks for your feedback!
(0015452)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-05-05 08:22 gbonney New Issue
2011-05-05 08:22 gbonney File Added: screenshots.zip
2011-05-05 08:42 Julian Note Added: 0014796
2011-05-05 09:08 gbonney Note Added: 0014797
2011-05-05 09:28 Julian Note Added: 0014798
2011-05-05 10:30 fman Note Added: 0014799
2011-05-12 10:02 gbonney Note Added: 0014840
2011-05-12 10:35 gbonney Note Edited: 0014840 View Revisions
2011-05-12 10:45 gbonney Note Added: 0014841
2011-05-12 10:45 gbonney Status new => feedback
2011-05-12 11:03 Julian Assigned To => Julian
2011-05-12 11:03 Julian Status feedback => assigned
2011-05-12 11:05 Julian Note Added: 0014842
2011-05-12 11:05 Julian Status assigned => resolved
2011-05-12 11:05 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-05-12 11:05 Julian Resolution open => fixed
2011-05-12 11:05 Julian Note Added: 0014843
2011-05-12 13:05 Julian Summary Charts.php shows "Wrong ID" => Misspelled variable in polarion integration causing charts generation error
2011-05-12 13:05 Julian Relationship added child of 0004337
2011-07-02 13:49 fman Note Added: 0015452
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker