Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004423TestLinkTest Specificationpublic2011-04-15 07:412011-07-02 13:49
ReporterKarlReichert 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004423: option $g_prefix_name_for_copy does not work when copying a Test Suite
DescriptionOne can configure how a copy of a Test Suite is named by option $g_prefix_name_for_copy

In default installation, the copy date and time is attached, so the option is set to $g_prefix_name_for_copy = strftime("%Y%m%d-%H:%M:%S", time());

I want the string "KOPIE VON" to be attached on the name, so my configuration looks like this:
$tlCfg->check_names_for_duplicates = ENABLED;
$tlCfg->action_on_duplicate_name = 'generate_new';
$g_prefix_name_for_copy = "KOPIE %s";

However, when I copy a Test Suite, still the date and time is attached for the new name. No "KOPIE 2" is attached. So this configuration option has no effect, as always the default behavoir is used.
Steps To Reproduce1) Set configuration options in custom_config_inc.php:
$tlCfg->check_names_for_duplicates = ENABLED;
$tlCfg->action_on_duplicate_name = 'generate_new';
$g_prefix_name_for_copy = "KOPIE %s";
2) copy an existing Test Suite
3) check the name of the copy --> it is not as expected ("KOPIE 2"), but date and time is attached on the Test Suite copy's name
Additional Information0004405:0014641 may state a solution for that, however I don't understand what is meant.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0015461)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-04-15 07:41 KarlReichert New Issue
2011-04-15 17:29 fman Status new => resolved
2011-04-15 17:29 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-04-15 17:29 fman Resolution open => fixed
2011-04-15 17:29 fman Assigned To => fman
2011-07-02 13:49 fman Note Added: 0015461
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker