Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004398TestLinkMigration/Upgrade Testlinkpublic2011-04-10 17:272011-07-02 13:49
ReporterJulian 
Assigned ToJulian 
PriorityhighSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004398: Prevent user-login when database scheme version does not fit required scheme
DescriptionPrevent user-login when database scheme does not fit required scheme.

Like this users will be informed in an early state that testlink cannot operate properly in this state. Users are forced to have correct database.
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0014545)
Julian (reporter)
2011-04-11 08:51

Reminder sent to: fman

I only found checkSchemaVersion() on configCheck.php

Is this the function you were talking about?
(0014548)
fman (administrator)
2011-04-11 09:37

yes
(0014551)
Julian (reporter)
2011-04-11 11:54

will remove reference to SCHEMA_CHANGES from upgrade message because file was deleted with the reason "not enough time to maintain".

file still exists on master and will be removed there too
(0014552)
Julian (reporter)
2011-04-11 12:11

branch 1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/31d23af7767b634be4e7a26895ed1545fce30068 [^]

master:
http://gitorious.org/testlink-ga/testlink-code/commit/35819c350228c32bf87b1eae1110c26c705be142 [^]

Please review changes. I tested as good as i can but maybe missed some case.
(0014553)
Julian (reporter)
2011-04-11 12:20

to test i modified db_version table (Testlink 1.9.1 installed) -> DB 1.4

1. update db_version set version='DB 1.3' where notes = 'TestLink 1.9.1'
2. try to login
-> login forbidden with message:
Manual upgrade of your DB scheme necessary (1.9.0 -> 1.9.1) - Read README file!

3. update db_version set version='DB 1.2' where notes = 'TestLink 1.9.1'
4. try to login
-> login forbidden with message:
You need to upgrade your Testlink Database to DB 1.4 -
click here access install and upgrade page
(0015466)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-04-10 17:27 Julian New Issue
2011-04-11 08:51 Julian Note Added: 0014545
2011-04-11 09:37 fman Note Added: 0014548
2011-04-11 11:54 Julian Note Added: 0014551
2011-04-11 12:11 Julian Note Added: 0014552
2011-04-11 12:11 Julian Assigned To => Julian
2011-04-11 12:11 Julian Status new => feedback
2011-04-11 12:20 Julian Note Added: 0014553
2011-04-11 12:20 Julian Status feedback => assigned
2011-04-14 09:39 Julian Status assigned => resolved
2011-04-14 09:39 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-04-14 09:39 Julian Resolution open => fixed
2011-07-02 13:49 fman Note Added: 0015466
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker