Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004343TestLinkReportspublic2011-03-22 14:282011-07-02 13:48
ReporterJulian 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004343: Reports Failed Test Cases / Blocked Test Cases / Not Run Test Cases -> Build is not shown
DescriptionReports Failed Test Cases / Blocked Test Cases / Not Run Test Cases -> Build is not shown.

Seems like something changed on function get_linked_tcversions() on testplan.class.php .

Francisco hope it is ok to assign to you as you know most about this function and added a big warning ;)
Steps To Reproduce1. Execute 1 Test Case -> Failed
2. Go to Test Reports -> Failed Test Cases
Additional Informationimoortant seems to be this error on event log:
E_NOTICE Undefined variable: more_exec_fields - in /home/www/testlink/lib/functions/testplan.class.php - Line 922

+ many times:
E_NOTICE Undefined index: build_name - in /home/www/testlink/lib/results/resultsByStatus.php - Line 264
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix_4343.zip [^] (36,799 bytes) 2011-03-23 11:02

- Relationships
has duplicate 0004459closedJulian Failed Test Cases Report 
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0014208)
fman (administrator)
2011-03-22 15:04
edited on: 2011-03-22 15:08

OK, sorry.
Will give a look on next days
This is a side effect of trying to get results ONLY for active builds.
Need to understand we need test a lot more.

(0014211)
fman (administrator)
2011-03-22 18:17

1.9.x
http://gitorious.org/testlink-ga/testlink-code/commit/a83b2cff0ca65b49f040c4cfb737a8e39cb45d56 [^]
(0014221)
Julian (reporter)
2011-03-23 11:03

seems to be ok - attached fix
(0015405)
fman (administrator)
2011-07-02 13:48

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-03-22 14:28 Julian New Issue
2011-03-22 14:28 Julian Status new => assigned
2011-03-22 14:28 Julian Assigned To => fman
2011-03-22 15:04 fman Note Added: 0014208
2011-03-22 15:08 fman Note Edited: 0014208 View Revisions
2011-03-22 18:17 fman Note Added: 0014211
2011-03-23 11:02 Julian File Added: fix_4343.zip
2011-03-23 11:03 Julian Note Added: 0014221
2011-03-23 11:03 Julian Status assigned => resolved
2011-03-23 11:03 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-03-23 11:03 Julian Resolution open => fixed
2011-03-23 11:03 Julian Relationship added child of 0004337
2011-05-21 06:41 Julian Relationship added has duplicate 0004459
2011-07-02 13:48 fman Note Added: 0015405
2011-07-02 13:48 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker