Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004322TestLinkTest Specificationpublic2011-03-14 18:422011-07-02 13:49
Reporterfman 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004322: New Option to block delete of executed test cases.
DescriptionDefault = DISABLED
$tlCfg->testcase_cfg->can_delete_executed = DISABLED;
TagsNo tags attached.
Database (MySQL,Postgres,etc)N/A
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon test_case_bulk_delete_with_platforms.png [^] (19,771 bytes) 2011-04-04 06:57


png file icon issue-4322-platforms.png [^] (22,270 bytes) 2011-04-16 07:53


png file icon issue-4322-bulk-delete-tc-platforms.png [^] (41,784 bytes) 2011-04-16 07:57


png file icon bulk_delete_no_platforms.PNG [^] (14,529 bytes) 2011-04-17 12:54


png file icon issue-4322-01.png [^] (25,044 bytes) 2011-05-28 17:49


? file icon issue_4322.odt [^] (108,937 bytes) 2011-06-09 09:11

- Relationships
related to 0004650closedJulian "Delete this version" button not work in Test Case edit 
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0014062)
fman (administrator)
2011-03-19 13:53

Branch 1.9
http://gitorious.org/testlink-ga/testlink-code/commit/5698cc23f170c24ca832338007fcd36579720171 [^]
(0014369)
fman (administrator)
2011-03-30 18:39

OK will improve
(0014407)
fman (administrator)
2011-04-02 10:03

Forbid to delete executed test cases via bulk test case delete feature on test suite level
1. Click on test suite that contains a test case that has been executed and cannot be deleted
2. Click on "Test Case Operations - Delete"
3. NO Check WILL BE PRESENT ON the test case that should not be possible to delete
(0014408)
fman (administrator)
2011-04-02 10:03

Forbid to delete test suites that contain executed test cases
1. Click on test suite that contains a test case that has been executed and cannot be deleted
2. Click on "Test Suite Operations - Delete"

DELETE BUTTON WILL NOT BE available, and message will give feedback to user.
(0014415)
Julian (reporter)
2011-04-04 06:56
edited on: 2011-04-04 10:04

Forbid to delete executed test cases via bulk test case delete feature on test suite level
1. Click on test suite that contains a test case that has been executed and cannot be deleted
2. Click on "Test Case Operations - Delete"
3. NO Check WILL BE PRESENT ON the test case that should not be possible to delete


-> when test case is assigned to 2 platforms but only executed for 1 platform delete is allowed. should be blocked if test case has been executed for any platform


Forbid to delete test suites that contain executed test cases
1. Click on test suite that contains a test case that has been executed and cannot be deleted
2. Click on "Test Suite Operations - Delete"

DELETE BUTTON WILL NOT BE available, and message will give feedback to user.

-> works, but message is not ok with platforms:

"Test suite can not be deleted, because system configuration blocks delete of executed test cases

tc1 Linked to one or more Test Plan, but not executed"

-> tc1 has been executed for 1 of 3 platforms

(0014677)
fman (administrator)
2011-04-16 07:53

>> Forbid to delete test suites that contain executed test cases
>> 1. Click on test suite that contains a test case that has been executed and
>> cannot be deleted
>> 2. Click on "Test Suite Operations - Delete"

>> DELETE BUTTON WILL NOT BE available, and message will give feedback to user.

Fixed but in a simpler way, because giving detailed information regarding on how many test plan and how many platforms tc has been executed requires IMHO too much work -> worthless.
see attached image with message (issue-4322-platforms.png)
(0014678)
fman (administrator)
2011-04-16 07:56

>>Forbid to delete executed test cases via bulk test case delete feature on test suite level
>>1. Click on test suite that contains a test case that has been executed and cannot be deleted
>>2. Click on "Test Case Operations - Delete"
>>3. NO Check WILL BE PRESENT ON the test case that should not be possible to delete
>>
>>
>> -> when test case is assigned to 2 platforms but only executed for 1
>> platform delete is allowed. should be blocked if test case has been executed >> for any platform

see attached image (issue-4322-bulk-delete-tc-platforms.png)
(0014679)
fman (administrator)
2011-04-16 07:59
edited on: 2011-04-16 08:06

Branch 1.9
Need to use:
http://gitorious.org/testlink-ga/testlink-code/commit/5698cc23f170c24ca832338007fcd36579720171 [^] [^]

AND
http://gitorious.org/testlink-ga/testlink-code/commit/7a99f118a186ab3c1df3b9c4fc85e5100ee7f19e [^]


Commited also to HEAD

(0014680)
fman (administrator)
2011-04-16 08:06

Reminder sent to: Julian

Please retest when you will have time
Thanks
(0014686)
Julian (reporter)
2011-04-17 12:55

i think we got a problem again now when no platforms are used. see attached screenshot: bulk_delete_no_platforms.PNG
(0014980)
fman (administrator)
2011-05-28 17:37
edited on: 2011-05-29 07:53

Settings
Configure TL to DO NOT ALLOW delete of executed test cases

1. cancel test suite where there is ONE TEST CASE EXECUTED

preconditions:
ONLY 1 test plan
ONLY 1 build
test cases have ONLY 1 version
NO PLATFORMS

1.1 Create a test suite on TOP LEVEL => direct chield of Test project
1.2 Create inside test suite 4 test cases
1.3 Create a test plan
1.4 Create a build
1.5 Assign whole test suite contents to test plan
1.6 execute JUST ON TEST CASE
1.7 Go to test spec
1.8 Select Test Suite and ask to delete

Result
Delete blocked BUT messagge is not good => see attached file issue-4322-01

(0014981)
fman (administrator)
2011-05-29 07:55

2. cancel test suite where there is ONE TEST CASE WITH MULTIPLE VERSIONS
   with EXECUTED in JUST ONE VERSION

preconditions:
ONLY 1 test plan
ONLY 1 build
test cases have N versions
NO PLATFORMS

2.1 Create a test suite on TOP LEVEL => direct chield of Test project
2.2 Create inside test suite 4 test cases
2.3 Create a test plan
2.4 Create a build
2.5 Assign whole test suite contents to test plan
2.6 execute JUST ON TEST CASE
2.7 Go to test spec
2.8 Select Test Suite and ask to delete
(0014982)
fman (administrator)
2011-05-29 08:19

3. cancel SINGLE TEST CASE WITH MULTIPLE VERSIONS with EXECUTED in JUST ONE VERSION

preconditions:
ONLY 1 test plan
ONLY 1 build
test cases have N versions
NO PLATFORMS

3.1 Create a test suite on TOP LEVEL => direct chield of Test project
3.2 Create inside test suite 4 test cases
3.3 Create a test plan
3.4 Create a build
3.5 Assign whole test suite contents to test plan
3.6 execute JUST ON TEST CASE
3.7 Go to test spec
3.8 Select THE TEST CASE and ASK to delete
(0014984)
fman (administrator)
2011-05-29 09:55

Seems finally fixed on 1.9 and head

here link for 1.9
http://gitorious.org/testlink-ga/testlink-code/commit/7287a73513a7e8ccd469975a0e31dc647140ab38 [^]
(0014985)
fman (administrator)
2011-05-29 09:56

Reminder sent to: Julian

@Julian
Please if you have time, retest
(0015192)
Julian (reporter)
2011-06-09 09:11

Lot of work to test this issue again - that is the reason for the delay.

I will attach a document with pictures explaining problems.

Major problems are:
- Delete is also blocked if test cases are not execute
- Delete not working if test cases are not added to any test plan
- some bad user feedback messages

Some issues are duplicate but i described for test plans WITH platforms and WITHOUT platforms.

Might be if you start fixing for issues that includes the use of platform that it might be already fixed for non-platform issues.
(0015211)
fman (administrator)
2011-06-09 20:51

Thanks a lot for tests!!

here fixes (just one file)

HEAD
http://gitorious.org/testlink-ga/testlink-code/commit/8a4e7a8f21d6f38693bdade93e384550190fcc0c [^]

1.9
http://gitorious.org/testlink-ga/testlink-code/commit/f54b8721ad76293be13c24fc107b8d445c1aaf44 [^]
(0015216)
Julian (reporter)
2011-06-10 07:13

Seems to work ok now.
Did not test if $tlCfg->testcase_cfg->can_delete_executed is ENABLED.
(0015432)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-03-14 18:42 fman New Issue
2011-03-19 10:10 fman Description Updated View Revisions
2011-03-19 13:50 fman Status new => resolved
2011-03-19 13:50 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-03-19 13:50 fman Resolution open => fixed
2011-03-19 13:50 fman Assigned To => fman
2011-03-19 13:53 fman Note Added: 0014062
2011-03-19 13:55 fman Relationship added child of 0004337
2011-03-30 18:39 fman Note Added: 0014369
2011-04-02 10:03 fman Note Added: 0014407
2011-04-02 10:03 fman Note Added: 0014408
2011-04-04 06:56 Julian Note Added: 0014415
2011-04-04 06:56 Julian File Added: bulk_delete_platforms.png
2011-04-04 06:57 Julian File Deleted: bulk_delete_platforms.png
2011-04-04 06:57 Julian File Added: test_case_bulk_delete_with_platforms.png
2011-04-04 10:04 Julian Note Edited: 0014415 View Revisions
2011-04-06 11:03 Julian Status resolved => assigned
2011-04-06 11:03 Julian Resolution fixed => reopened
2011-04-16 07:53 fman Note Added: 0014677
2011-04-16 07:53 fman File Added: issue-4322-platforms.png
2011-04-16 07:56 fman Note Added: 0014678
2011-04-16 07:57 fman File Added: issue-4322-bulk-delete-tc-platforms.png
2011-04-16 07:59 fman Note Added: 0014679
2011-04-16 08:06 fman Note Edited: 0014679 View Revisions
2011-04-16 08:06 fman Note Added: 0014680
2011-04-17 12:54 Julian File Added: bulk_delete_no_platforms.PNG
2011-04-17 12:55 Julian Note Added: 0014686
2011-05-21 08:26 Julian Fixed in Version 1.9.3 (2011 Q3 - bug fixing) =>
2011-05-28 17:37 fman Note Added: 0014980
2011-05-28 17:48 fman Note Edited: 0014980 View Revisions
2011-05-28 17:49 fman File Added: issue-4322-01.png
2011-05-29 07:53 fman Note Edited: 0014980 View Revisions
2011-05-29 07:55 fman Note Added: 0014981
2011-05-29 08:19 fman Note Added: 0014982
2011-05-29 09:55 fman Note Added: 0014984
2011-05-29 09:56 fman Note Added: 0014985
2011-06-09 09:11 Julian Note Added: 0015192
2011-06-09 09:11 Julian File Added: issue_4322.odt
2011-06-09 20:51 fman Note Added: 0015211
2011-06-10 07:13 Julian Note Added: 0015216
2011-06-10 07:13 Julian Status assigned => resolved
2011-06-10 07:13 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-06-10 07:13 Julian Resolution reopened => fixed
2011-07-02 13:49 fman Note Added: 0015432
2011-07-02 13:49 fman Status resolved => closed
2011-08-08 08:12 Julian Relationship added related to 0004650



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker