Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004305TestLinkUser Interface Generalpublic2011-03-08 22:062011-07-02 13:49
Reporterfishfan77 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWin 7, XPOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004305: The test cases tree shows nothing when creating test cases
DescriptionThe test cases tree shows nothing when creating test cases. Have to click “Reset Filters” to make it appear again after test case has been created.
Steps To Reproduce1. Create new test case
2. Enter all fields
3. click SAVE

Left hand pane should refresh and show the test case that was just created. It doesnt.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL 2005
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon test link refresh error.jpg [^] (88,636 bytes) 2011-03-09 18:03


png file icon Screenshot-2.png [^] (13,109 bytes) 2011-03-09 19:19

- Relationships
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0013820)
fman (administrator)
2011-03-09 07:32

1. upgrade to 1.9.1
2. retest
3. check your config.inc.php
(0013826)
fishfan77 (reporter)
2011-03-09 14:19

1. We are Running 1.9.1 (Prague) as we are in all test cases submitted.
2. Still does this

3. What do I need to look for in the config.inc.php file?
(0013828)
Julian (reporter)
2011-03-09 14:34
edited on: 2011-03-09 14:55

as no one else reported this issue it is pretty likely that you have configured something for filters (or something else) on config file that is not working (config.inc.php or custom_config.inc.php)

-> you need to analyze your configuration to provide us detailed steps to reproduce. returning to default configuration would be the quickest step to check if it is a configuration problem

(0013829)
fishfan77 (reporter)
2011-03-09 14:57

We have nothing configured for filters. We used the default installation and have not added anything to any of the config files
(0013831)
Julian (reporter)
2011-03-09 17:56

without further info we will resolve this issue as "unable to reproduce"
(0013832)
fishfan77 (reporter)
2011-03-09 18:03
edited on: 2011-03-09 18:23

1.Click on Edit Test Cases
2.In the lower left hand pane-click on a sub-folder that contains test cases
3.Click on "Create Test Case"
4.Enter All information for test case
5.Click CREATE
6.Test case is created, after 5-10 seconds screen refreshes and left hand Pane is empty. (See attached screenshot)

We are doing NO special filtering or changing anything in our config file.

(0013833)
Julian (reporter)
2011-03-09 18:59

what DB do you use ? N/A is not the information we need, as i suppose you use a database if not there might be a problem :)
(0013834)
fishfan77 (reporter)
2011-03-09 19:05

SQL 2005. Sorry, I forgot to enter that, I wasnt sure and our IT person wasnt around yesterday
(0013835)
fman (administrator)
2011-03-09 19:12

This problem can be created for the interaction between ADODB PHP MSSQL DRIVERS and DB.
When there is some error (missing column name, bad column name, etc) all become slow.
Can you use MSSQL 2005 profiler to trace the offending SQL sentence ?
(0013836)
fishfan77 (reporter)
2011-03-09 19:14

Its not that it is slow, the pane shows nothing (does not refresh) after creating a new test case. If you refresh the pane, then it shows the correct number of test cases for that folder
(0013837)
fman (administrator)
2011-03-09 19:16

OK for the other issues that result on blank page please trace.
(0013838)
fman (administrator)
2011-03-09 19:18

what about your settings section that is not displayed ?
I'm attaching an image with right setting.
(0014224)
fishfan77 (reporter)
2011-03-23 13:04

Yes "Update tree after every Operation" is enabled
(0014298)
fman (administrator)
2011-03-26 08:13
edited on: 2011-03-26 17:10

tested on 1.9.2 SQLSERVER 2008 EXPRESS, WINDOWS 7 with xampp => OK

(0014324)
fishfan77 (reporter)
2011-03-28 13:21

If you can reopen this, I will attach our DB
(0014326)
fman (administrator)
2011-03-28 14:50

this was tested with db you posted on other issue => do not think your db is needed
(0014347)
fishfan77 (reporter)
2011-03-29 13:51

The link you gave us in our other issue fixed filtering. Thanks!
(0014348)
fishfan77 (reporter)
2011-03-29 14:02

I see you closed the other filtering issue we had, you can go ahead and close this one. It appears to be working correctly now after our DBA applied the fixes/changes you suggested.

Thank you for all of your help!
(0014353)
fman (administrator)
2011-03-29 16:36

be carefull you have use link I've put yesterday night
(0015183)
fishfan77 (reporter)
2011-06-08 17:45

We just upgraded to 1.9.2 (Prague). This is happening again. I believe there was a fix for this, you had given me a link to a fix. I cant seem to find that link on this issue anymore.

We upgraded to 1.9.2 and are seeing this again. It did work in 1.9.1 after you gave us a link to a fix
(0015186)
fman (administrator)
2011-06-08 18:25

issue has been declared solved on 1.9.3 then you do not have to waste our time reopening it because does not work on 1.9.2
(0015187)
fishfan77 (reporter)
2011-06-08 19:09

You guys told me for the last month to upgrade to 1.9.2, which you claim is the "stable version". NOW you are telling me this doesn’t work in 1.9.2 but it does in 1.9.3.... This issue worked in 1.9.1 so why not now. You need to stop jerking us around with all of your builds. WHAT is the latest Build???? You told me 1.9.2 we just spent a day upgrading. You say we are wasting YOUR time? We spent a whole day upgrading to 1.9.2 as you told us to. Now, you tell us something that worked in 1.9.1 doesn’t work and we have to use 1.9.3????? This is totally unacceptable.

Our test team now has to REFRESH the page after each and every test case they create. Talk about waste of time.

EVERY issue I opened, someone on your end would ALWAYS respond with a nasty or sarcastic remark. We upgraded to 1.9.2 just as you told us. You said it was the latest stable version, I don’t want to hear about 1.9.3. This is something that YOU broke, it was working in 1.9.1 and it doesn’t work. It hinders us greatly when we try to use YOUR tool to complete OUR job.
(0015434)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-03-08 22:06 fishfan77 New Issue
2011-03-09 07:32 fman Note Added: 0013820
2011-03-09 14:19 fishfan77 Note Added: 0013826
2011-03-09 14:34 Julian Note Added: 0013828
2011-03-09 14:34 Julian Note Edited: 0013828 View Revisions
2011-03-09 14:55 Julian Note Edited: 0013828 View Revisions
2011-03-09 14:57 fishfan77 Note Added: 0013829
2011-03-09 17:56 Julian Note Added: 0013831
2011-03-09 18:03 fishfan77 Note Added: 0013832
2011-03-09 18:03 fishfan77 File Added: test link refresh error.jpg
2011-03-09 18:23 fishfan77 Note Edited: 0013832 View Revisions
2011-03-09 18:59 Julian Note Added: 0013833
2011-03-09 19:05 fishfan77 Note Added: 0013834
2011-03-09 19:12 fman Note Added: 0013835
2011-03-09 19:14 fishfan77 Note Added: 0013836
2011-03-09 19:15 fman Database N/A => MSSQL 2005
2011-03-09 19:16 fman Note Added: 0013837
2011-03-09 19:18 fman Note Added: 0013838
2011-03-09 19:19 fman File Added: Screenshot-2.png
2011-03-23 13:04 fishfan77 Note Added: 0014224
2011-03-26 08:11 fman Note Added: 0014295
2011-03-26 08:13 fman Note Added: 0014298
2011-03-26 08:13 fman Status new => resolved
2011-03-26 08:13 fman Resolution open => unable to reproduce
2011-03-26 08:13 fman Assigned To => fman
2011-03-26 17:10 fman Note Deleted: 0014295
2011-03-26 17:10 fman Note Edited: 0014298 View Revisions
2011-03-28 13:21 fishfan77 Note Added: 0014324
2011-03-28 13:21 fishfan77 Status resolved => assigned
2011-03-28 13:21 fishfan77 Resolution unable to reproduce => reopened
2011-03-28 14:50 fman Note Added: 0014326
2011-03-29 13:51 fishfan77 Note Added: 0014347
2011-03-29 14:02 fishfan77 Note Added: 0014348
2011-03-29 16:36 fman Note Added: 0014353
2011-03-29 16:36 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-03-29 16:36 fman Status assigned => resolved
2011-03-29 16:36 fman Resolution reopened => fixed
2011-03-29 16:37 fman Relationship added child of 0004337
2011-06-08 17:45 fishfan77 Note Added: 0015183
2011-06-08 17:45 fishfan77 Status resolved => assigned
2011-06-08 17:45 fishfan77 Resolution fixed => reopened
2011-06-08 18:25 fman Note Added: 0015186
2011-06-08 18:25 fman Status assigned => resolved
2011-06-08 18:25 fman Resolution reopened => fixed
2011-06-08 19:09 fishfan77 Note Added: 0015187
2011-06-08 19:09 fishfan77 Status resolved => assigned
2011-06-08 19:09 fishfan77 Resolution fixed => reopened
2011-06-08 19:20 fman Status assigned => resolved
2011-06-08 19:20 fman Resolution reopened => fixed
2011-07-02 13:49 fman Note Added: 0015434
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker