Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004298TestLinkRequirement Managementpublic2011-03-07 11:132011-07-02 13:49
ReporterJulian 
Assigned Toasimon 
PriorityhighSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004298: Direct links for each requirement version
Descriptionshow globe icon to create direct link for each requirement version.

for latest version show 2 links:
link for requirment (independant from version) = current behaviour
link for actual latest requirement version
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0004487closedJulian Add Req-Version to internal Requirement Links 

-  Notes
(0014991)
asimon (developer)
2011-05-30 13:47

Enhanced direct linking functionality to be able to link to specific requirement versions.

Branch 1.9: https://gitorious.org/testlink-ga/testlink-code/commit/ffe4c26c05b538bffeb7b969cbcbeb7793a2169b [^]

Master branch is yet to do, therefore this issue is not yet resolved.
Because of the large number of recent changes on master, this merge will take a little while - I'm working on it.
(0015040)
asimon (developer)
2011-06-01 17:12

Another commit to branch 1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/1b77ccd7ed45816db00322a67088b998d85e0c1c [^]

linkto.php now displays a new link to the current version of a requirement when a nonexistent version of a valid requirement is requested.

Merge to 2.0 still todo.
(0015119)
asimon (developer)
2011-06-03 14:52

Changes in branch 1_9 have been merged into master.
At the moment this is only done locally, push will follow, since at the moment technical problems in our network prevent me from connecting to our main repository...

There is a general problem with linkto.php on branch master, though. It is not working at all, linkto.php does not open anything other than the main page. I assume this is caused by the recent changes to master regarding the session problems. I will have to inspect this further to find out what is causing this problem. This is only an issue on version 2.0, not for next release in 1.9 branch.

There is another problem which is influencing both branches: if you open a specific version of a requirement using linkto.php, you cannot delete that specific version using the "Delete" button on the opened page. The "Delete" button is displayed instead of the "Delete version" button, which should be there. But this problem does not only affect the usage of linkto.php, it also is an issue when opening requirement versions using the JS-generated popup windows, which is used for example in requirement overview or some reports. So we should address that specific bug/problem in another, separate issue.
(0015156)
asimon (developer)
2011-06-07 08:30

Technical problems are resolved, so I could push my changes of last week to our repository: http://gitorious.org/testlink-ga/testlink-code/commit/e83c4d5e395c6c4c9c8484b0d6cbca392fc102fb [^]
Merge of changes from 1.9 to master is complete.
(0015395)
Julian (reporter)
2011-07-02 13:25

This is fixed Andreas - right ?
(0015396)
Julian (reporter)
2011-07-02 13:32

I suppose this is fixed - reopen if it is not.
(0015418)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-03-07 11:13 Julian New Issue
2011-03-07 11:13 Julian Status new => assigned
2011-03-07 11:13 Julian Assigned To => asimon
2011-05-23 09:47 Julian Note Added: 0014903
2011-05-23 12:38 Julian Relationship added related to 0004487
2011-05-23 12:39 Julian Note Deleted: 0014903
2011-05-30 13:47 asimon Note Added: 0014991
2011-06-01 17:12 asimon Note Added: 0015040
2011-06-03 14:52 asimon Note Added: 0015119
2011-06-07 08:30 asimon Note Added: 0015156
2011-07-02 13:25 Julian Note Added: 0015395
2011-07-02 13:32 Julian Note Added: 0015396
2011-07-02 13:32 Julian Status assigned => resolved
2011-07-02 13:32 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-07-02 13:32 Julian Resolution open => fixed
2011-07-02 13:49 fman Note Added: 0015418
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker