Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004290TestLinkReportspublic2011-03-03 16:182012-09-01 19:58
Reporterpvmeerbe 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004290: Test report 'Overall build status' : incorrect counters when no test cases assigned
DescriptionAs of TestLink version 1.9.1 the Test Reports > General test plan metrics : Overall build status now shows the passed/failed/blocked/not run counters for assigned test cases only.In previous versions ALL test cases assigned to the test plan were counted (see http://mantis.testlink.org/view.php?id=3406 [^])

However, the failed/passed/blocked counters are currently still calculated on ALL test cases added to the test plan.



Steps To ReproduceScenario:
- add 10 test cases to a test plan
- do NOT assigned them to a person
- execute one of them as each type (passed/blocked/failed)
- look at the report

Result:
- Assigned & not run counters are set to 0 (which is correct since none of the test cases are assigned to a person
- Failed , blocked & passed counters are set to 1 (which is not correct since only the passed/blocked/failed test cases which are assigned should be counted)

Quick fix:
-------------
A simple (ugly) solution is to change lib/functions/results.class.php line 835:

if( $status_verbose !='' && $status_verbose != 'not_run' )

to

if( $status_verbose !='' && $status_verbose != 'not_run' && $totalCases != 0 )
TagsNo tags attached.
Database (MySQL,Postgres,etc)psql
Browserfirefox 3.6.9
PHP Version5.2.10
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0017261)
fman (administrator)
2012-09-01 19:58

1.9.4 released

- Issue History
Date Modified Username Field Change
2011-03-03 16:18 pvmeerbe New Issue
2012-08-17 19:09 fman Task Workflow Status => TBD
2012-08-17 19:09 fman Status new => resolved
2012-08-17 19:09 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-17 19:09 fman Resolution open => fixed
2012-08-17 19:09 fman Assigned To => fman
2012-09-01 19:58 fman Note Added: 0017261
2012-09-01 19:58 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker