Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004289TestLinkRequirement Managementpublic2011-03-03 15:472011-07-02 13:48
Reportermikil 
Assigned Tofman 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformApache 2.2OSWindowsOS VersionWindows Server 2
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004289: (MS SQL Server 2008) - Opening a requirement crashes
DescriptionWhen I click to open a requirement, Testlink freezes and timeouts.

My platform is:
*Win Server 2008 R2
*Apache 2.2
*PHP 5.2.17
*MS SQL Server 2008
Steps To Reproduce1. Click "Requirement Specification" on top menu
2. Select a requirement
3. Testlink timeouts / crashes
Additional InformationI've added logging and discovered that it freezes here:

function: initialize_gui
...
$gui->req_has_history = count($req_mgr->get_history($gui->req_id, array('output' => 'array'))) > 1;
...
TagsNo tags attached.
Database (MySQL,Postgres,etc)MS SQL Server 2008
BrowserFirefox 3.6.14
PHP Version5.2.17
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0013780)
mikil (reporter)
2011-03-03 15:53

The php-file that is referenced on Additional information is:
..\lib\requirements\reqView.php
(0013781)
Julian (reporter)
2011-03-03 19:06

did you migrate your database to 1.9.1 with manual steps from readme ?
(0013808)
mikil (reporter)
2011-03-08 06:21
edited on: 2011-03-08 06:21

I installed a clean installation of 1.9.1.

(0013809)
mikil (reporter)
2011-03-08 06:41

Ok, now that Julian pointed me to the right direction I got it working. I needed to run this from db migration script:

-- Step 3 new tables
CREATE TABLE /*prefix*/req_revisions(
  parent_id int NOT NULL,
    id int NOT NULL,
  revision INTEGER NOT NULL DEFAULT '1',
    req_doc_id varchar(64) NULL,
    name varchar(100) NULL,
  scope TEXT NULL DEFAULT NULL,
  status CHAR(1) NOT NULL DEFAULT 'V',
  type CHAR(1) NULL DEFAULT NULL,
  active INT NOT NULL DEFAULT '1',
  is_open INT NOT NULL DEFAULT '1',
  expected_coverage INT NOT NULL DEFAULT 1,
  log_message TEXT NULL DEFAULT NULL,
  author_id INT NULL DEFAULT NULL,
    creation_ts datetime NOT NULL CONSTRAINT /*prefix*/DF_req_revisions_creation_ts DEFAULT (getdate()),
  modifier_id INT NULL DEFAULT NULL,
    modification_ts datetime NULL,
  CONSTRAINT /*prefix*/PK_req_revisions PRIMARY KEY CLUSTERED
  (
      id
  ) ON [PRIMARY]
) ON [PRIMARY];

CREATE UNIQUE NONCLUSTERED INDEX /*prefix*/IX1_req_revisions ON /*prefix*/req_revisions
(
    parent_id,revision
) ON [PRIMARY];



I suggest you revise the documentation on 1.9.1 since I did not realise that a clean install of 1.9.1 needed any migration or fix the db creation script of 1.9.1 so that no migration steps are needed on a clean install. Anyway, thank you Julian for helping me to solve my problem!
(0013810)
Julian (reporter)
2011-03-08 07:43

Reminder sent to: fman

This seems only to be an issue with mssql.

Francisco could you please take a look.

This issue does not exist for MySQL.
(0014066)
fman (administrator)
2011-03-20 10:39

can get code for 1.9.x on:
http://gitorious.org/testlink-ga/testlink-code/commit/41bb0abadc0c5c6be2b657c06babebd8c1631e21 [^]
(0015417)
fman (administrator)
2011-07-02 13:48

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-03-03 15:47 mikil New Issue
2011-03-03 15:53 mikil Note Added: 0013780
2011-03-03 19:06 Julian Note Added: 0013781
2011-03-04 10:38 Julian Status new => feedback
2011-03-08 06:21 mikil Note Added: 0013808
2011-03-08 06:21 mikil Status feedback => new
2011-03-08 06:21 mikil Note Edited: 0013808 View Revisions
2011-03-08 06:41 mikil Note Added: 0013809
2011-03-08 07:43 Julian Note Added: 0013810
2011-03-17 18:49 fman Assigned To => fman
2011-03-17 18:49 fman Status new => assigned
2011-03-20 10:39 fman Note Added: 0014066
2011-03-20 10:39 fman Status assigned => resolved
2011-03-20 10:39 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-03-20 10:39 fman Resolution open => fixed
2011-03-20 10:40 fman Summary Opening a requirement crashes => (MS SQL Server 2008) - Opening a requirement crashes
2011-03-20 10:41 fman Relationship added child of 0004337
2011-07-02 13:48 fman Note Added: 0015417
2011-07-02 13:48 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker