Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004271TestLinkBug Tracking Systems Integrationpublic2011-02-23 15:382016-09-08 15:13
Reportergbonney 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004271: Polarion Bugtracking Interface
Description1.
Change the int_bugtracking.php.
Search:
$btslist = array('BUGZILLA','MANTIS','JIRA', 'JIRASOAP',.....
TODO:
Add 'POLARION' to this array.
2.
Change the config.inc.php.
Set bugtracking to POLARION.

New files are attached.
TagsNo tags attached.
Database (MySQL,Postgres,etc)none
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon polarion_bugtracking_v0.4.zip [^] (2,327 bytes) 2011-02-23 15:38

- Relationships

-  Notes
(0013733)
gbonney (reporter)
2011-02-23 15:47

here are the locale informations:
en_US/en_GB:
// ----- int_polarion.php -----
// Used to display at User interface label as title attribute
// Attention must follow rule: issue_status_, because there is logic
// build on this.
//
$TLS_issue_status_open = "Open";
$TLS_issue_status_accepted = "Accepted";
$TLS_issue_status_inprogress = "In progress";
$TLS_issue_status_confirmed = "Confirmed";
$TLS_issue_status_assigned = "Assigned";
$TLS_issue_status_resolved = "Resolved";
$TLS_issue_status_tested = "Tested";
$TLS_issue_status_delivered = "Delivered";
$TLS_issue_status_closed = "Closed";
$TLS_issue_status_held = "Held";

de_DE:
// ----- int_polarion.php -----
// Used to display at User interface label as title attribute
// Attention must follow rule: issue_status_, because there is logic
// build on this.
//
$TLS_issue_status_open = "Offen";
$TLS_issue_status_accepted = "In Bearbeitung";
$TLS_issue_status_inprogress = "In Bearbeitung";
$TLS_issue_status_confirmed = "Bestätigt";
$TLS_issue_status_assigned = "Zugeteilt";
$TLS_issue_status_resolved = "Entwickelt";
$TLS_issue_status_tested = "Getestet";
$TLS_issue_status_delivered = "Geliefert";
$TLS_issue_status_closed = "Geschlossen";
$TLS_issue_status_held = "Im Wartezustand";
(0013896)
fman (administrator)
2011-03-18 09:43

Thanks
I've requested an extende eval period to polarion company to test you work but get no answer
(0013900)
fman (administrator)
2011-03-18 16:38

I'm going to refactor a little bit your code before commiting.
I will need your help to test it.
(0013909)
fman (administrator)
2011-03-18 19:03

code refactored commited for release 1.9.2
(0014726)
gbonney (reporter)
2011-04-20 13:49

Testing your work now!
(0014844)
gbonney (reporter)
2011-05-12 11:14

Found a bug in int_polarion.php - a misspelled variable.
Bug has been fixed and committed in 0004455.

This issue should be closed?
(0025379)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2011-02-23 15:38 gbonney New Issue
2011-02-23 15:38 gbonney File Added: polarion_bugtracking_v0.4.zip
2011-02-23 15:47 gbonney Note Added: 0013733
2011-03-18 09:43 fman Note Added: 0013896
2011-03-18 16:38 fman Note Added: 0013900
2011-03-18 19:03 fman Note Added: 0013909
2011-04-20 13:49 gbonney Note Added: 0014726
2011-05-12 11:14 gbonney Note Added: 0014844
2011-05-12 11:14 gbonney Status new => feedback
2011-05-12 12:48 Julian Status feedback => resolved
2011-05-12 12:48 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-05-12 12:48 Julian Resolution open => fixed
2011-05-12 12:48 Julian Assigned To => fman
2016-09-08 15:13 fman Note Added: 0025379
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker