Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004253TestLinkTest Plan (builds, milestones, test assign)public2011-02-17 15:062011-03-18 19:08
Reporterphidotnet 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows 7 + ChromeOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004253: Filter 'Result=Not Run' in page "Assign Test Case Execution" does not work if test plan has ONLY 1 build
DescriptionIn case the test plan has only one build, the filter does not work if user wants to list Not Run test cases.
Steps To Reproduce1) Create new test plan
2) Add 5 test cases into the test plan
3) Create a new build in the test plan
4) Execute/Update test result for 3 test cases for the build
5) Navigate to page "Assign Test Case Execution"
6) Filter Not Run test cases to assign to someone else

Actual result:
There is NOT any test cases listed

Expected result:
There are 2 Not Run test cases showed in the left tree
(Attached screen shots are captured when the issue happens)

Additional Information- If the test plan has more than 1 build the issue does not happen
- The fix fix_4203.zip has been applied on the tested build
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon Issue - Filter in Assign Test Case Execution.png [^] (56,511 bytes) 2011-02-17 15:06


png file icon Correct - General Test Plan Metrics.png [^] (44,729 bytes) 2011-02-17 15:07


png file icon Correct - Filter in Test Execution.png [^] (70,536 bytes) 2011-02-17 15:09

- Relationships
child of 0004185closedfman Availables Fixes for 1.9.1 (Prague) 

-  Notes
(0013713)
fman (administrator)
2011-02-21 19:37

Reminder sent to: asimon

do you think you can take care of this ?
(0013720)
asimon (developer)
2011-02-22 08:27

I've just reproduced the bug - I'll take a look and check if I find the problem.
(0013722)
asimon (developer)
2011-02-22 15:25

Fix for 1.9: http://gitorious.org/testlink-ga/testlink-code/commit/8adabf17dfb1b8ee78b98fe0b9f5522f2e2170fa [^]

Fix for master: http://gitorious.org/testlink-ga/testlink-code/commit/6ec5cb9ce9b56b79955c9544a40221f998553ffc [^]

Found & fixed for both branches. The problem was that the value of the disabled select input (filter method) was not sent by the form, so the wrong filter method was chosen to filter the results in this special case.
(0013957)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-02-17 15:06 phidotnet New Issue
2011-02-17 15:06 phidotnet File Added: Issue - Filter in Assign Test Case Execution.png
2011-02-17 15:07 phidotnet File Added: Correct - General Test Plan Metrics.png
2011-02-17 15:09 phidotnet File Added: Correct - Filter in Test Execution.png
2011-02-21 19:37 fman Note Added: 0013713
2011-02-22 08:27 asimon Note Added: 0013720
2011-02-22 08:41 asimon Assigned To => asimon
2011-02-22 08:41 asimon Status new => assigned
2011-02-22 15:25 asimon Note Added: 0013722
2011-02-22 15:26 asimon Relationship added child of 0004185
2011-02-22 15:26 asimon Status assigned => resolved
2011-02-22 15:26 asimon Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-02-22 15:26 asimon Resolution open => fixed
2011-03-18 19:08 fman Note Added: 0013957
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker