Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004250TestLinkTest Specificationpublic2011-02-16 17:092011-03-18 19:08
Reporterphidotnet 
Assigned ToJulian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows 7 + ChromeOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004250: Cannot cancel 'Create step' mode
DescriptionAfter saving change in "Create step" mode, the button Cancel does not work anymore
Steps To Reproduce1) Navigate Test Specification area
2) Create new test case
3) Select the new test case in the left tree and select "Create step"
4) Enter text into Step 1 and save
5) Enter text into Step 2 and save
6) Click on the Step 1 to edit
7) Update Step 1 and save
8) Click the button Cancel

Actual result:
- Nothing happens on the screen. The screen is still in "Create step" mode
- Message displays in the Error Console of browser
----------------------------------------------------
Error: missing ; before statement
Source File: http://qc-pc1:8080/testlink/lib/testcases/tcEdit.php [^]
Line: 1, Column: 38
Source Code:
show_modified_warning=false; location='http://qc-pc1:8080/testlink/lib/testcases/archiveData.php?tcase_id=29873&show_mode=show|escape:'url''; [^]
----------------------------------------------------

Expected result:
User is able to quit the "Create step" mode by clicking the button Cancel
Additional InformationThe problem happens in both Chrome and Firefox 3.6.13
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome + Firefox 3.6.13
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon Cannot cancel Create step mode.png [^] (52,264 bytes) 2011-02-16 17:09

- Relationships
duplicate of 0003737closedJulian Step Edit - Cancel Button not working anymore 

-  Notes
(0013659)
Julian (reporter)
2011-02-17 12:48

http://gitorious.org/testlink-ga/testlink-code/commit/99de46d3279ee667ff0011b1638d9e08e38dc86c [^]

http://gitorious.org/testlink-ga/testlink-code/commit/f35ef0ad6c129bd7b9a68fad9b02c8b2a515c02c [^]
(0013965)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-02-16 17:09 phidotnet New Issue
2011-02-16 17:09 phidotnet File Added: Cannot cancel Create step mode.png
2011-02-17 12:16 Julian Relationship added duplicate of 0003737
2011-02-17 12:46 Julian Assigned To => Julian
2011-02-17 12:46 Julian Status new => assigned
2011-02-17 12:48 Julian Note Added: 0013659
2011-02-17 12:48 Julian Status assigned => resolved
2011-02-17 12:48 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-02-17 12:48 Julian Resolution open => fixed
2011-03-18 19:08 fman Note Added: 0013965
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker