Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004246TestLinkTest Plan (builds, milestones, test assign)public2011-02-16 05:352011-03-18 19:08
Reporterhaisland 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS VersionXP SP3
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004246: Suggest to add snap to grid in test plan management GUI
DescriptionTestlink 1.9.1 supports test plan export and import, but it's really hard for the user to find which export/import button is for which plan.
Steps To Reproduce1. Create many test plan (3 or more).
2. Enter Test Plan Management GUI.
3. Try to export or import test plan to local drive.

Result:
  If Test Plan Management page exist many test plan (e.g. 10 or more), it's difficult for user to find the correct export/import button to click to perform their purpose, maybe original case will be modified if clicking import button for another test plan.

  So suggest to add snap to grid for this GUI to make sure the click is related button.
Additional InformationTest plan export/import is really a very good feature.
Our company is using Testlink 1.8.5, which not support this feature, so the snap to grid feature reqeust is not needed, but I do believe we need this when we migrate to Testlink 1.9.x.

Thank you.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE7
PHP Version5.2
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon 0004246.JPG [^] (159,083 bytes) 2011-02-16 05:40


jpg file icon 4246_#EEE.JPG [^] (47,129 bytes) 2011-02-20 08:37

- Relationships
child of 0004185closedfman Availables Fixes for 1.9.1 (Prague) 
child of 0004382closedJulian Usability: Improve simple table for better readability (row background color, hovering effects, horizontal seperators ...) 

-  Notes
(0013635)
Julian (reporter)
2011-02-16 12:29

this requires central change of simple table template i think.

@Francisco: i think simple table is also used for test steps etc -> does it fit for all tables that use this style ? if not -> reject
(0013643)
fman (administrator)
2011-02-16 18:00

I would like to understand what is 'snap to grid'
please explain in detail

One option we add as button title 'export' + testplan name
(0013647)
haisland (reporter)
2011-02-17 02:30

Sorry for the confuse of "snap to grid" because English is not my mother language.

Please refer to attached screenshot, in "Test Plan Management" page, there are many test plan items and relative Export/Import buttons, it seems difficult for the user to find correct Export/Import button, for example, if they want to import test plan .xml file for one certain test plan, but they press Import button of another test plan by mistake, it maybe cause another test plan is overwritten by incorrect data.

So my suggestion is to add different background color to each item (refer to attached screenshot also) to help the user find corresponding button easily.

Thank you.
(0013649)
fman (administrator)
2011-02-17 06:11

Now things are a little bit clear, try always to explain what you do in simple and common terms.
Snap to grid is IMHO absolutely different that ' having backoung color that alternate on each row'
Think using smarty you can change the template to do what you want.
But imho this is not the solution.
will discuss with team to understand what can be done.
(0013650)
fman (administrator)
2011-02-17 06:13

@julian:
what about this
http://www.permadi.com/tutorial/cssHighlightTableRow/index.html [^]

(surely you have thought about)
(0013653)
Julian (reporter)
2011-02-17 07:52

I do not plan to make a change here but of course makes sense to have alternating row coloring -> your choice.
(0013685)
fman (administrator)
2011-02-19 10:01
edited on: 2011-02-19 11:15

Please try this
{foreach item=testplan from=$gui->tplans}
<tr onMouseOver="this.bgColor='#CDDEF3';" onMouseOut="this.bgColor='#EEE';">

Instead of
{foreach item=testplan from=$gui->tplans}
<tr>

and let me know what you think

Tested OK on Firefox fedora, chrome fedora.
Problems with opera fedora => '#EEE' => become black, but '#EEEEEE' works OK.

then:
<tr onMouseOver="this.bgColor='#CDDEF3';" onMouseOut="this.bgColor='#EEEEEE';">

need to check what is right way to express color on HEX TRIPLET.
Seems both #EEE and #EEEEEE are synonyms => do not understand why opera does not like

(0013690)
haisland (reporter)
2011-02-20 08:35
edited on: 2011-02-20 08:37

fman, I checked your suggestion and the solution is good.

As for #EEE, the problem also occur with IE7 and IE8 (Ubuntu8.1 server + Windows XP SP3), refer to 4246_#EEE.jpg.
It's OK if use #EEEEEE.

(0013695)
fman (administrator)
2011-02-20 15:46

fix for 1.9.1 -
http://gitorious.org/testlink-ga/testlink-code/commit/0b5be0ab068fcdcf51cdd99d0081569b3d7d5471 [^]
(0013958)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-02-16 05:35 haisland New Issue
2011-02-16 05:40 haisland File Added: 0004246.JPG
2011-02-16 12:29 Julian Note Added: 0013635
2011-02-16 18:00 fman Note Added: 0013643
2011-02-17 02:30 haisland Note Added: 0013647
2011-02-17 06:11 fman Note Added: 0013649
2011-02-17 06:13 fman Note Added: 0013650
2011-02-17 07:52 Julian Note Added: 0013653
2011-02-19 10:01 fman Note Added: 0013685
2011-02-19 10:04 fman Note Edited: 0013685 View Revisions
2011-02-19 10:07 fman Note Edited: 0013685 View Revisions
2011-02-19 10:08 fman Note Edited: 0013685 View Revisions
2011-02-19 10:09 fman Assigned To => fman
2011-02-19 10:09 fman Status new => assigned
2011-02-19 11:15 fman Note Edited: 0013685 View Revisions
2011-02-20 08:35 haisland Note Added: 0013690
2011-02-20 08:37 haisland File Added: 4246_#EEE.JPG
2011-02-20 08:37 haisland Note Edited: 0013690 View Revisions
2011-02-20 15:46 fman Note Added: 0013695
2011-02-20 15:50 fman Status assigned => resolved
2011-02-20 15:50 fman Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-02-20 15:50 fman Resolution open => fixed
2011-02-20 15:51 fman Relationship added child of 0004185
2011-03-18 19:08 fman Note Added: 0013958
2011-03-18 19:08 fman Status resolved => closed
2011-04-06 10:47 Julian Relationship added child of 0004382



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker