Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004243TestLinkTest Executepublic2011-02-15 15:212011-03-29 06:38
ReporterFalcon1 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWAMPPOSWindows ServerOS Version2003 R2
Product Version1.9 (Prague) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004243: When creating a new build without "Copy tester assignments", the test cases remain assigned to users of the previous build
DescriptionWhen I create a new build leaving the check box Copy tester assignments unselected, in the Test Case Execution the test cases results assigned to the user of the previous build, although in the Assign Testers to test execution section they results unassigned. Also if I change the filter in the Settings or Filters sections, it results assigned to the user of the previous build.
Steps To ReproduceCreate a test plan with some test cases.
Create a platform.
Create a build.
Assign test cases to a user for that platform and that build.
Save an execution for the test cases.
Create a new build and leave the checkbox Copy tester assignments unselected.
Try to execute the test case and you can see that the test case is assigned to the user of the previous build, although it has not been assigned for this new build.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.0.41
BrowserFirefox 3.6.13
PHP Version5.2.3
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon 4243_bad_user.png [^] (3,093 bytes) 2011-02-15 16:06

- Relationships

-  Notes
(0013620)
Julian (reporter)
2011-02-15 15:36
edited on: 2011-02-15 15:37

have you closed the previous build or chosen the newest build on text execution settings box?

(0013621)
Falcon1 (reporter)
2011-02-15 16:05

I did more tests, and the situation is more complex.
This is another use case.
1. Create and assign Build1 to User1
2. Create and assign Build2 to User2
3. Create and assign Build3 to User3

In the test execution the test case is rightly assigned based on what is selected in the field Build to execute of the Setting section, while in the section of the attached image 4243_bad_user.png the user indicated in the Assigned to : is wrong.

Now try to unassing the test case of the Build3. All the assignment of the three build will be lost. The same thing happens if you try to unassign the test case of another build.
(0013622)
Falcon1 (reporter)
2011-02-15 16:09

There are previous build closed (the first ones) and other not closed (the last ones). In total there are more than ten builds. If you want I can attach a screenshot of the build situation.
(0013623)
Julian (reporter)
2011-02-15 16:22

Duplicate of 0004203 i think. Apply fix and give us feedback.
(0013624)
Falcon1 (reporter)
2011-02-15 16:36

Ok, with fix of the 0004203 the problem of lost assignment seems resolved, while the user indicated in the image 4243_bad_user.png sometimes continues to be wrong.
(0013625)
Julian (reporter)
2011-02-15 16:59

So the test case shows up for the right user but simply the wrong user is displayed?

For Example:

TC1 is assigned to User1
User1 clicks execute and is able to see TC1
User1 clicks the node of TC1 in the tree -> wrong user is shown on execution page ?
(0013626)
Falcon1 (reporter)
2011-02-15 17:09

Exactly.
(0014335)
Julian (reporter)
2011-03-29 06:38

Would you be so kind to create a seperate issue for the problem that still exists? I will set to resolved here because the initial problem was solved with TL 1.9.2.
(0014336)
Julian (reporter)
2011-03-29 06:38

released with TL 1.9.2

- Issue History
Date Modified Username Field Change
2011-02-15 15:21 Falcon1 New Issue
2011-02-15 15:36 Julian Note Added: 0013620
2011-02-15 15:37 Julian Note Edited: 0013620 View Revisions
2011-02-15 16:05 Falcon1 Note Added: 0013621
2011-02-15 16:06 Falcon1 File Added: 4243_bad_user.png
2011-02-15 16:09 Falcon1 Note Added: 0013622
2011-02-15 16:22 Julian Note Added: 0013623
2011-02-15 16:36 Falcon1 Note Added: 0013624
2011-02-15 16:59 Julian Note Added: 0013625
2011-02-15 17:09 Falcon1 Note Added: 0013626
2011-03-29 06:38 Julian Note Added: 0014335
2011-03-29 06:38 Julian Status new => resolved
2011-03-29 06:38 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-03-29 06:38 Julian Resolution open => fixed
2011-03-29 06:38 Julian Assigned To => Julian
2011-03-29 06:38 Julian Note Added: 0014336
2011-03-29 06:38 Julian Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker