Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004231TestLinkTest Plan (builds, milestones, test assign)public2011-02-08 15:042013-05-30 19:42
Reporteratrabelsi 
Assigned Toasimon 
PriorityurgentSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0004231: Add a filter on test importance while adding TCs to a test plan
DescriptionAdd a filter on test importance while adding TCs to a test plan
Additional InformationThis issue is very important since the test plan is principally based on test importance.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Testlink
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Test Importance Filter not provided while adding test cases to Test Plan.PNG [^] (68,237 bytes) 2011-04-14 09:27

- Relationships
duplicate of 0004217newasimon No way to filter by "Test importance" 
has duplicate 0004413closedJulian Test Priority Filter not availble while Adding Test Cases to Test Plan 
has duplicate 0004071closedJulian Test Plan definition improvment 
related to 0002985closedJulian Expose test case IMPORTANCE (NOT priority) as a column in the 'Add / Remove Test cases to Test Plan' frame. 

-  Notes
(0014615)
spacomp (reporter)
2011-04-14 11:18

Also See Issue No 0002985
(0014651)
Julian (reporter)
2011-04-15 11:53

Here we might not be able to fix, because:

Imagine a test case with 3 version:
v1 -> importance = low
v2 -> importance = medium
v3 -> importance = high

When we want to add this test case to test plan we do not know what the appropriate importance could be.
(0014661)
atrabelsi (reporter)
2011-04-15 16:50

Genarally, Importance will be the same for the 3 versions.

Suppose that a test case has 3 versions:
v1 -> Execution type = Manual
v2 -> importance = Manual
v3 -> importance = Automated

I think that the filter has to applicable on the last version.
(0014684)
Julian (reporter)
2011-04-17 07:24

please explain your last comment.

v1 -> Execution type = Manual
v2 -> importance = Manual
v3 -> importance = Automated

copy/paste error?
(0015106)
atrabelsi (reporter)
2011-06-03 07:36

sorry!!!

the idea is that we can have a test case with 3 versions and each time a different Execution type.

v1 -> Execution type = Manual
v2 -> Execution type = Manual
v3 -> Execution type = Automated

The Execution type filter is already done (i think on last version). So you can add Importance also.
(0015107)
Julian (reporter)
2011-06-03 08:00

This issue is targeted for 2.0 - we will find a solution

- Issue History
Date Modified Username Field Change
2011-02-08 15:04 atrabelsi New Issue
2011-02-08 16:13 Julian Assigned To => asimon
2011-02-08 16:13 Julian Status new => assigned
2011-04-14 09:09 Julian Relationship added has duplicate 0004413
2011-04-14 09:27 spacomp File Added: Test Importance Filter not provided while adding test cases to Test Plan.PNG
2011-04-14 09:36 Julian Relationship added related to 0004217
2011-04-14 11:18 spacomp Note Added: 0014615
2011-04-14 11:21 Julian Relationship added related to 0002985
2011-04-15 11:53 Julian Note Added: 0014651
2011-04-15 16:36 Julian Relationship added has duplicate 0004071
2011-04-15 16:50 atrabelsi Note Added: 0014661
2011-04-17 07:24 Julian Note Added: 0014684
2011-06-03 07:36 atrabelsi Note Added: 0015106
2011-06-03 08:00 Julian Note Added: 0015107
2012-08-30 10:15 asimon Relationship replaced parent of 0004217
2012-10-10 12:03 asimon Relationship replaced duplicate of 0004217
2012-10-10 12:04 asimon Task Workflow Status => READY FOR TESTING
2012-10-10 12:04 asimon Status assigned => resolved
2012-10-10 12:04 asimon Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2012-10-10 12:04 asimon Resolution open => fixed
2013-05-30 19:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker