Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004230TestLinkTest Specificationpublic2011-02-08 10:142011-03-18 19:08
Reporterstealz 
Assigned ToJulian 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSXPOS Version
Product Version 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004230: JS error when editing test case (step)
DescriptionTestLink 1.9.1

Clicking on a test step (add new step and save or edit step and save), and the following error occurs:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)
Timestamp: Mon, 27 Sep 2010 15:20:22 UTC

Message: Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept the focus.
Line: 307
Char: 5
Code: 0
URI: http://testlink-dev.skytrac.org/lib/testcases/tcEdit.php [^] [^]

After closing this error, editing can proceed.
Additional Informationnot reproducible under FireFox
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
BrowserIE7 IE8
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0013560)
Julian (reporter)
2011-02-08 13:25
edited on: 2011-02-08 14:15

I am having the same error but works as it should. JS Error is only indicated by a "!" on the lower left of IE. Error message does only appear if i double click this icon.

it is caused by:

document.forms[0].step_number.focus();

on gui/templates/testcases/tcStepEdit.tpl

this seems not to work - i can only guess that this should set the focus to the editor.

as a workaround simply comment it.

(0013569)
fman (administrator)
2011-02-08 20:37

@Julian:
ok, can you fix this with your solution ?
(0013978)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-02-08 10:14 stealz New Issue
2011-02-08 13:25 Julian Note Added: 0013560
2011-02-08 13:35 Julian Note Edited: 0013560 View Revisions
2011-02-08 13:41 Julian Priority high => low
2011-02-08 13:41 Julian Severity major => minor
2011-02-08 14:15 Julian Note Edited: 0013560 View Revisions
2011-02-08 20:37 fman Note Added: 0013569
2011-02-09 08:31 Julian Assigned To => Julian
2011-02-09 08:31 Julian Status new => assigned
2011-02-11 07:51 Julian Status assigned => resolved
2011-02-11 07:51 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-02-11 07:51 Julian Resolution open => fixed
2011-03-18 19:08 fman Note Added: 0013978
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker