Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004221TestLinkReportspublic2011-02-04 17:452011-03-18 19:08
Reporterfyl 
Assigned ToJulian 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform09 x86_64 x86_64 x86_64 GNU/LinuOS09 x86_64 x86_64 x86_64 GNU/LinuOS Version09 x86_64 x86_64
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004221: Test Results matrix HTML: File does not exist: \\*gui\\
DescriptionThe "Test Results Matrix" report will not run in HTML. I can run it as an EXCEL file and that works. All the other reports work fine.


root@testlinkdev2 bin]# ./httpd -v
Server version: Apache/2.2.14 (Unix)
Server built: Feb 22 2010 15:08:51

mysql> select version();
+------------------------------+
| version() |
+------------------------------+
| 5.1.31sp1-enterprise-gpl-pro |
+------------------------------+
1 row in set (0.00 sec)

java version "1.4.2"


Steps To ReproduceSelect the Current Test Plan.
Select "Test reports and Metrics"
Select "Test result Matrix"

Additional InformationFirebug uncovered this:
It seems that the following Java Script executes while trying to run "Test result matrix": ext-all.js

b is undefined
[Break On This Error] (function(){var h=Ext.util,k=Ext.each,...lclick",this.onNodeDblClick,this)}});
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql 5.1.31
BrowserFirefox, Chrome, Safari
PHP Version5.3.0
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon ext-all-js.png [^] (216,033 bytes) 2011-02-04 19:18


xls file icon MB221_test_spec-2011-02-04.xls [^] (53,533 bytes) 2011-02-04 19:21

- Relationships
duplicate of 0004195closedfman Debug Messages on Reports ( for example: Query Metrics ) 

-  Notes
(0013510)
fyl (reporter)
2011-02-04 18:06

I tried updating Java from 1.4 to 1.6 and still see the same "b is undefined" for java script ext-all.js (line 7).
(0013512)
fyl (reporter)
2011-02-04 18:15

New version of Java:

java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03, mixed mode)
(0013513)
fyl (reporter)
2011-02-04 18:19

Apache Error log while trying to run the "TEST RESULTS MATRIX"

[Fri Feb 04 10:18:17 2011] [error] [client 66.92.181.162] File does not exist: /usr/local/httpd/htdocs/testlink/lib/results/gui, referer: http://66.92.181.178/testlink/lib/results/resultsTC.php?format=0&tplan_id=16595 [^]
(0013514)
fyl (reporter)
2011-02-04 18:20

Contents of /usr/local/httpd/htdocs/testlink/lib/results:

[root@testlinkdev2 logs]# cd ../htdocs/testlink/lib/results/
[root@testlinkdev2 results]# ls
charts.inc.php metricsDashboard.php printDocument.php resultsGeneral.php resultsReqs.php topLevelSuitesBarChart.php
charts.php overallPieChart.php priorityBarChart.php resultsImport.php resultsTC.php uncoveredTestCases.php
displayMgr.php ownerBarChart.php resultsBugs.php resultsMoreBuildsGUI.php testCasesWithCF.php
freeTestCases.php platformPieChart.php resultsByStatus.php resultsMoreBuilds.php testCasesWithoutTester.php
keywordBarChart.php printDocOptions.php resultsByTesterPerBuild.php resultsNavigator.php testPlanWithCF.php
(0013515)
fman (administrator)
2011-02-04 18:43

never add a big amount of text pasted on a note is absolutely unreadable then useless and terribly annoying.
Why is important java version ? we are not using java?
Adding contents of a folder is also useless

in short like it or not your report is a mess.
(0013516)
fyl (reporter)
2011-02-04 19:14

The report works fine if you tell it to export as an EXCEL Document.
I am sorry about the annoying posts. I was merely trying to supply you with as much information as possible to have a complete picture of what was going on.

A JAVA script is being called when you generate the report. Install Firebug and you will see what I mean.

I can attach the successful run of the report as an excel file if it will help you.
(0013517)
fyl (reporter)
2011-02-04 19:20

I have attached a screen shot of the error when executing the report. All other reports run fine and do not generate this error. To my knowledge this report is a canned TESTLINK report.
(0013518)
fyl (reporter)
2011-02-04 19:22

I have also attached the successful run of the report as an Excel file for your reference.

Since TESTLINK calls this java script then the version of JAVA will have some impact.
(0013553)
fyl (reporter)
2011-02-07 17:47

Can I provide any additional information to help resolve this issue?
(0013629)
lois@rockyou.com (reporter)
2011-02-15 20:29
edited on: 2011-02-15 20:40

I am able to export the test results matrix as an emailed HTML report, but we cannot display as HTML... couldn't glean anything useful our of the userlog*.txt files.

My personal feeling is that there is something to look at in the lib/results/resultsTC.php code - ?

(0013724)
fyl (reporter)
2011-02-22 20:08

fMAN-
Would it possible to acknowledge/confirm this issue? R
(0013725)
Julian (reporter)
2011-02-22 20:53

have you applied this fix: 0004195

if not please do so.
(0013734)
fyl (reporter)
2011-02-23 16:59

Julian-
This resolved the issue. I noticed that the file already had most of the echo statements remarked. I simply remarked every echo statement in the file.
(0013952)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-02-04 17:45 fyl New Issue
2011-02-04 18:06 fyl Note Added: 0013510
2011-02-04 18:11 fyl Note Added: 0013511
2011-02-04 18:15 fyl Note Added: 0013512
2011-02-04 18:19 fyl Note Added: 0013513
2011-02-04 18:20 fyl Note Added: 0013514
2011-02-04 18:41 fman Note Deleted: 0013511
2011-02-04 18:43 fman Note Added: 0013515
2011-02-04 19:14 fyl Note Added: 0013516
2011-02-04 19:18 fyl File Added: ext-all-js.png
2011-02-04 19:20 fyl Note Added: 0013517
2011-02-04 19:21 fyl File Added: MB221_test_spec-2011-02-04.xls
2011-02-04 19:22 fyl Note Added: 0013518
2011-02-07 17:47 fyl Note Added: 0013553
2011-02-15 20:29 lois@rockyou.com Note Added: 0013629
2011-02-15 20:40 lois@rockyou.com Note Edited: 0013629 View Revisions
2011-02-22 20:08 fyl Note Added: 0013724
2011-02-22 20:53 Julian Note Added: 0013725
2011-02-23 06:32 Julian Status new => feedback
2011-02-23 16:59 fyl Note Added: 0013734
2011-02-23 16:59 fyl Status feedback => new
2011-02-23 17:11 Julian Status new => resolved
2011-02-23 17:11 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-02-23 17:11 Julian Resolution open => fixed
2011-02-23 17:11 Julian Assigned To => Julian
2011-02-23 17:12 Julian Relationship added duplicate of 0004195
2011-03-18 19:08 fman Note Added: 0013952
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker