Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004218TestLinkExport/Importpublic2011-02-03 01:312014-04-25 17:39
Reporterbjramsey 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformX86OSLinuxOS VersionXUbuntu 9.4
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.10 (2014 Q1 - bug fixing) 
Summary0004218: Import of Custom Fields Failing due to spaces...
DescriptionI have an import file that was run though tidy (html tidy in XML mode) and when I attempted to import it, the custom fields would not import. The problem is how the import function is processing spaces. This problem seems to impact only the custom fields, not the main fields, so I hope it is a simple fix.
Steps To ReproduceCreate file with defined custom fields that are "tidy"

    <custom_fields>
      <custom_field>
        <name>
          <![CDATA[QATrackSuiteID]]>
</name>
        <value>
          <![CDATA[TSC462-0.2]]>
</value>
      </custom_field>
    </custom_fields>


The same data will import correctly if the fields are as follows:

    <custom_fields>
      <custom_field>
        <name><![CDATA[QATrackSuiteID]]></name>
        <value><![CDATA[TSC462-0.2]]></value>
      </custom_field>
    </custom_fields>
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox
PHP Version5.2.10
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon ragged_file2.xml [^] (349 bytes) 2011-02-05 15:38
xml file icon testcase-192-1-ragged.xml [^] (1,087 bytes) 2011-02-06 08:50
zip file icon Case-0004218-SampleData.zip [^] (2,591 bytes) 2011-02-07 17:51

- Relationships
child of 0006048closedfman Availables hot-fixes for 1.9.9 & How To get full fixed package from gitorious 

-  Notes
(0013509)
fman (administrator)
2011-02-04 11:46

1. please avoid use of elipsis on issue subject
2. Can you explain what you spaces are talking about in addition to put the example and leave to us the task of try to understans what is happening .
3. you can contribute with the fix if you want
4. attach BOTH XML files instead of pasting on note, this way we can do same test done by you.
(0013521)
fman (administrator)
2011-02-05 15:04

1. creating a file with content provided result in a problem when trying to import Custom Field definition due to missing required values.

2. We need detailed steps to reproduce in order to assign to out task list.
(0013522)
fman (administrator)
2011-02-05 15:38

Tested Custom Field import definition using attached file -> no issues
(0013554)
bjramsey (reporter)
2011-02-07 17:50

My apologies. I am new to this project, and am not a PHP developer. I have obviously picked up some ticket habits from our work environment that do not conform to this community's conventions.

I am attaching a set of files that should demonstrate the issue. I included snippets because I can not deliver the actual XML files we are using. For these samples, I have sanitized a small fragment to show the issue. I am also including an export of the custom fields that have been defined, and an error file 'error_responses.txt'

The issue is simply that the import is reading a space before and after the CDATA sections, and is therefore unable to identify to match the custom field name, since the custom field does not have the spaces. It does not appear that this problem exists for standard fields, though I have not done any extensive testing to check.
(0013571)
fman (administrator)
2011-02-08 20:42

ok, thanks for samples
(0020864)
fman (administrator)
2014-04-25 17:39

1.9.10 released

- Issue History
Date Modified Username Field Change
2011-02-03 01:31 bjramsey New Issue
2011-02-04 11:46 fman Note Added: 0013509
2011-02-05 15:04 fman Note Added: 0013521
2011-02-05 15:38 fman Note Added: 0013522
2011-02-05 15:38 fman File Added: ragged_file2.xml
2011-02-05 16:09 fman Assigned To => fman
2011-02-05 16:09 fman Status new => feedback
2011-02-06 08:50 fman File Added: testcase-192-1-ragged.xml
2011-02-07 17:50 bjramsey Note Added: 0013554
2011-02-07 17:50 bjramsey Status feedback => assigned
2011-02-07 17:51 bjramsey File Added: Case-0004218-SampleData.zip
2011-02-08 20:42 fman Note Added: 0013571
2013-12-30 14:42 fman QA Team - Task Workflow Status => READY FOR TESTING
2013-12-30 14:42 fman Status assigned => resolved
2013-12-30 14:42 fman Fixed in Version => 1.9.10 (2014 Q1 - bug fixing)
2013-12-30 14:42 fman Resolution open => fixed
2013-12-30 14:42 fman Relationship added child of 0006048
2014-04-25 17:39 fman Note Added: 0020864
2014-04-25 17:39 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker