Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004214TestLinkExport/Importpublic2011-02-02 13:172015-09-19 08:49
Reportertaraujo 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0004214: Already executed test cases versions can be edited by importing an XML test case file
DescriptionWhen a test case is executed, the current version is locked for edition, but if an XML test case file is imported with modifications for this test case, the modifications are applied to the executed version, and they can be seen in the "Test Execution" area.
Steps To ReproducePreconditions:
 1. There is a suite with at least 1 test case available.
 2. This test case is part of a test plan and it has already been executed.

Steps:
 1. Export the test cases from this suite to an XML file: "Test Case Operations / Export"
 2. Edit the XML file and change the test case name: <testcase name="change_here">
 3. Select the option to import test cases to the same suite: "Test Case Operations / Import".
 4. Choose the previously edited file and select "Has same External ID" and "Update data on latest version" options.
 5. Select "Upload file" option.

 *** Now you can see the problem:
  - Expected: (a) An error is displayed informing the user that the current test case version could not be edited since it was already executed.
  - Found: The previously executed test case is edited.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySql
BrowserChrome
PHP Versionphp-5.2.9-2.fc10.i386
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0004213closedfman Duplicate test cases are created when importing new versions with edited TC Name (xml format) 
related to 0007177closedfman LATEST GITHUB CODE - Already executed test case can't be edit by import a modified xml-file 

-  Notes
(0013491)
taraujo (reporter)
2011-02-02 13:17

This issue is related to 4213
(0023034)
Mr.Bricodage (updater)
2015-04-03 21:33

issue still exists with TestLink 1.9.13.

TestCase already executed is modified using XML import using "Update data on Latest version" option.

13 sections "DB Acces Error - debug_print_backtrace()" are displayed on consultation of the testcase content (after import).
(0023914)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2011-02-02 13:17 taraujo New Issue
2011-02-02 13:17 taraujo Note Added: 0013491
2011-03-17 18:52 fman Relationship added related to 0004213
2011-05-28 17:36 fman Assigned To => fman
2011-05-28 17:36 fman Status new => assigned
2015-04-03 21:33 Mr.Bricodage Note Added: 0023034
2015-04-04 17:35 fman QA Team - Task Workflow Status => READY FOR TESTING
2015-04-04 17:35 fman Status assigned => resolved
2015-04-04 17:35 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-04-04 17:35 fman Resolution open => fixed
2015-06-25 15:41 fman Relationship added related to 0007177
2015-09-19 08:49 fman Note Added: 0023914
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker