Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004204TestLinkDatabase Generalpublic2011-01-30 01:522011-03-18 19:08
Reporterteacher.hostingjava 
Assigned Tofman 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004204: Error query using prefix table
DescriptionHello,
I found some errors in query if I set prefix table during installation.
For example:
\lib\functions\testcase.class.php --> function update_active_status
in update query there is tcversions but using prefix this table doesn't exist(e.g. tl_tcversions).
To resolve this problem need replace tcversions.id with {$this->tables['tcversions']}.id or id .

I found the same error in many php files for the other tables.

Thanks for your work

Regards
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySql 5.5
BrowserFirefox 3.6.13
PHP Version5.2.0
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0003849closedfman Edit test case fails to save 

-  Notes
(0013468)
fman (administrator)
2011-01-30 08:31
edited on: 2011-02-05 16:15

>>{$this->tables['tcversions']}.id
this is not the way to go, but REMOVING ALIAS to make UPDATE compatible with
MySQL
POSTGRES
MSSQL

will fix

(0013991)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-01-30 01:52 teacher.hostingjava New Issue
2011-01-30 08:31 fman Note Added: 0013468
2011-01-30 08:31 fman Assigned To => fman
2011-01-30 08:31 fman Status new => assigned
2011-02-05 16:14 fman Relationship added duplicate of 0003849
2011-02-05 16:15 fman Note Edited: 0013468 View Revisions
2011-02-05 16:15 fman Status assigned => resolved
2011-02-05 16:15 fman Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-02-05 16:15 fman Resolution open => fixed
2011-03-18 19:08 fman Note Added: 0013991
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker