Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004186TestLinkGeneralpublic2011-01-24 07:372011-03-18 19:08
ReporterJulian 
Assigned ToJulian 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004186: Log message on config_check.txt after upgrade to Testlink 1.9.1
DescriptionUnknown Schema version DB 1.4, please upgrade your Testlink Database to DB 1.3 is logged.

as config check warnings are displayed on main page this error forces users to set config check to silent -> major / high
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
child of 0004185closedfman Availables Fixes for 1.9.1 (Prague) 

-  Notes
(0013426)
Unhandled (reporter)
2011-01-25 13:55

Experiencing same issue. Looking at the 'db_version' table in my database:

mysql> select * from db_version;
+---------+---------------------+--------------------------------+
| version | upgrade_ts | notes |
+---------+---------------------+--------------------------------+
| DB 1.2 | 2009-07-09 07:07:30 | first version with API feature |
| DB 1.4 | 2011-01-23 18:26:08 | TestLink 1.9.1 |
+---------+---------------------+--------------------------------+
2 rows in set (0.00 sec)
(0013427)
Julian (reporter)
2011-01-25 14:21

if you like to fix this for now:

lib/functions/configCheck.php - function checkSchemaVersion() :

set $last_version to 'DB 1.4'
(0013437)
Julian (reporter)
2011-01-26 09:05

for 1.9 branch:
- defined TL_LAST_DB_VERSION on const.inc.php to not forget to update
- special message if manual upgrade is necessary for DB 1.3 to DB 1.4

for head:
- defined TL_LAST_DB_VERSION on const.inc.php to not forget to update
- no special message as i suppose a new DB 1.5 will be available for testlink 2.0 and special migration procedures to be able to simply upgrade from 1.3 or 1.4 to 1.5
(0013438)
Julian (reporter)
2011-01-26 09:06
edited on: 2011-01-26 09:15

@users: until next release use fix mentioned in comment #13427

(0013994)
fman (administrator)
2011-03-18 19:08

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2011-01-24 07:37 Julian New Issue
2011-01-25 13:55 Unhandled Note Added: 0013426
2011-01-25 14:21 Julian Note Added: 0013427
2011-01-26 09:05 Julian Note Added: 0013437
2011-01-26 09:05 Julian Status new => resolved
2011-01-26 09:05 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-01-26 09:05 Julian Resolution open => fixed
2011-01-26 09:05 Julian Assigned To => Julian
2011-01-26 09:06 Julian Note Added: 0013438
2011-01-26 09:06 Julian Note Edited: 0013438 View Revisions
2011-01-26 09:07 Julian Note Edited: 0013438 View Revisions
2011-01-26 09:07 Julian Relationship added child of 0004185
2011-01-26 09:15 Julian Note Edited: 0013438 View Revisions
2011-03-18 19:08 fman Note Added: 0013994
2011-03-18 19:08 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker