Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004164TestLinkCustom fieldspublic2011-01-12 14:432011-01-22 15:11
Reporterspacomp 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004164: Custom fields with "LIST" type remain wide open during use.
Description1. Created a Custom fields of type "List"
2. Assigned to Test Case development
3. When selected for "Edit Test Case" custom fields are appearing as if they kep wide opended.

Please check the attached image.


TagsNo tags attached.
Database (MySQL,Postgres,etc)My SQL
BrowserFire Fox
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon Custom_Fields_with_list_type_remain_wide_open.png [^] (47,132 bytes) 2011-01-12 14:43


txt file icon FIX_BUGID_4164.txt [^] (4,145 bytes) 2011-01-20 12:18 [Show Content]

- Relationships

-  Notes
(0013325)
spacomp (reporter)
2011-01-20 06:30

Any Update on this Issue?
(0013326)
Julian (reporter)
2011-01-20 10:00
edited on: 2011-01-20 12:24

not sure if perfect size is possible.

anyways a list with 1 item does not make sense.

we should check if "perfect size" is possible - if not - won't fix

//perfect size means (for me):

if the amount of items is less than 5 -> adjust size
if the amount of items is greater than 5 -> scrollbars

(0013327)
fman (administrator)
2011-01-20 10:11

@spamcomp
This kind of pressure over Dev Team is not liked and unfair

1. issue is not critic/ not blocking
2. you can not pretend a fix in less than a week
(0013329)
spacomp (reporter)
2011-01-20 10:41

@fman

Did it seem Pressurizing?, I am extremely sorry for it.

I posted on 12th of JAN and there was no single thread in this regard, thought of getting back to contributors.
(0013331)
Julian (reporter)
2011-01-20 11:45

if you are interested in fixing this issue take a look at
lib/functions/cfield_mgr.class.php - function string_custom_field_input()

all you need is in there
(0013333)
Julian (reporter)
2011-01-20 12:19

attached potential fix.

let me know if this works for you. please read carefully. was not possible to attach the whole file because of other changes that first apply for TL 1.9.1
(0013337)
spacomp (reporter)
2011-01-21 04:36

@Julian,

Tried the code, Following are the observations.

if the amount of items is less than 4 -> adjust size
if the amount of items is greater than 4 -> scrollbars
(0013348)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2011-01-12 14:43 spacomp New Issue
2011-01-12 14:43 spacomp File Added: Custom_Fields_with_list_type_remain_wide_open.png
2011-01-20 06:30 spacomp Note Added: 0013325
2011-01-20 10:00 Julian Note Added: 0013326
2011-01-20 10:02 Julian Note Edited: 0013326 View Revisions
2011-01-20 10:02 Julian Note Edited: 0013326 View Revisions
2011-01-20 10:11 fman Note Added: 0013327
2011-01-20 10:41 spacomp Note Added: 0013329
2011-01-20 11:45 Julian Note Added: 0013331
2011-01-20 12:18 Julian File Added: FIX_BUGID_4164.txt
2011-01-20 12:19 Julian Note Added: 0013333
2011-01-20 12:24 Julian Note Edited: 0013326 View Revisions
2011-01-20 14:38 Julian Assigned To => Julian
2011-01-20 14:38 Julian Status new => feedback
2011-01-21 04:36 spacomp Note Added: 0013337
2011-01-21 04:36 spacomp Status feedback => assigned
2011-01-21 08:00 Julian Status assigned => resolved
2011-01-21 08:00 Julian Fixed in Version => 1.9.1 (bug fixing)
2011-01-21 08:00 Julian Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013348
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker