Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004144TestLinkTest Specificationpublic2011-01-06 15:232011-01-22 15:11
ReporterKarlReichert 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004144: VERTICAL LAYOUT - missing "insert step" column and icon in test case specification
DescriptionAs described by fman in http://www.teamst.org/forum/viewtopic.php?f=11&t=3806&start=0&sid=589488bb8798ee001c7eb33480f43bdf#p10647 [^] and seen in this screenshot http://mantis.testlink.org/file_download.php?file_id=2019&type=bug [^] (not taken from my TestLink installation), right next to the button for deleting a test step and its expected result there shall be a button displayed to insert a step in between existing test steps.

However, as seen in my screenshot missingIcon.png, in my TestLink installation this column and the icon for doing this is missing, i.e. I cannot insert a test step in between existing ones, only adding at the end is possible.

As described by fman in http://www.teamst.org/forum/viewtopic.php?f=11&t=3806&start=0&sid=589488bb8798ee001c7eb33480f43bdf#p10671, [^] this bug seems to be present only, if $tlCfg->spec_cfg->steps_results_layout is set to 'vertical'.
Additional InformationAccording to fman, this is due to the fact, that INSERT icon is not managed with VERTICAL LAYOUT: http://www.teamst.org/forum/viewtopic.php?f=11&t=3806&start=0&sid=589488bb8798ee001c7eb33480f43bdf#p10671 [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.1.36
BrowserFirefox 3.6.13
PHP Version5.2.11
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon missingIcon.png [^] (37,364 bytes) 2011-01-06 15:24


gz file icon fix-4144.tar.gz [^] (1,694 bytes) 2011-01-08 09:45

- Relationships
child of 0004039closed Availables Fixes for 1.9.0 (Prague) 

-  Notes
(0013214)
fman (administrator)
2011-01-08 09:45

use attached fix (cleanup templates_c directory) and let us know
(0013225)
KarlReichert (reporter)
2011-01-10 08:55
edited on: 2011-01-10 08:55

Hello fman. Thank you very much for the supplied fix. This solves the issue!

(0013226)
KarlReichert (reporter)
2011-01-10 09:42

However, this fix seems to cause another issue:
If I set $tlCfg->spec_cfg->steps_results_layout = 'horizontal', the step and expected result are arranged side-by-side, when creating a step. But after saving, when reading the test specification, they are arranged vertical.
(0013230)
fman (administrator)
2011-01-10 20:30

1. get testlink 1.9.0 from sourceforge
2. apply fixes :
4144 and 4136
3. copy custom*.example custom_config.inc.php
4. put line
$tlCfg->spec_cfg->steps_results_layout = 'vertical';
in custom_config.inc.php
5. test -> all is VERTICAL
6. edit -> custom_config.inc.php
comment line added on step 4
7. test -> all ok
(0013239)
KarlReichert (reporter)
2011-01-11 08:48

Hello fman. When doing the steps you described, everything works as it should, i.e. the bug seems to be solved.

When doing this on my old installation, the described bug (comment 0004144:0013226) still occurs. But I guess, this is due to a lot of "playing around" and applying test fixes on that installation, so this installation is already in an unstable state.

So I think we can consider this bug as fixed. If the issue described in comment 0004144:0013226 will appear again with a fresh/updated installation, I will reopen this issue again ...

Thanks a lot for your work to fix this!
(0013363)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2011-01-06 15:23 KarlReichert New Issue
2011-01-06 15:24 KarlReichert File Added: missingIcon.png
2011-01-06 15:27 fman Assigned To => fman
2011-01-06 15:27 fman Status new => assigned
2011-01-06 15:28 fman Summary missing "insert step" column and icon in test case specification => VERTICAL LAYOUT - missing "insert step" column and icon in test case specification
2011-01-08 09:45 fman File Added: fix-4144.tar.gz
2011-01-08 09:45 fman Note Added: 0013214
2011-01-08 09:45 fman Status assigned => feedback
2011-01-08 09:46 fman Relationship added child of 0004039
2011-01-10 08:55 KarlReichert Note Added: 0013225
2011-01-10 08:55 KarlReichert Status feedback => assigned
2011-01-10 08:55 KarlReichert Note Edited: 0013225 View Revisions
2011-01-10 09:42 KarlReichert Note Added: 0013226
2011-01-10 20:30 fman Note Added: 0013230
2011-01-11 08:48 KarlReichert Note Added: 0013239
2011-01-11 21:38 fman Status assigned => resolved
2011-01-11 21:38 fman Fixed in Version => 1.9.1 (bug fixing)
2011-01-11 21:38 fman Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013363
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker