Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004128TestLinkReportspublic2010-12-28 05:592011-04-01 18:20
Reporterterryzuo 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004128: Report->Overall Build Status:the Assigned field is not correct sometimes
DescriptionOverall Build Status:the Assigned field value is not correct in the build that changed the assigned status.
See the attached snapshot.
Steps To Reproduce1.Changed the assigned to status in one build(i.e. 1216)
2.Report->Overall Build Status:the Assigned field value is not correct
See the attached snapshot.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL(XAMPP1.7.3)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon 12-28-2010 1-51-58 PM.png [^] (11,958 bytes) 2010-12-28 05:59


png file icon bug2.png [^] (11,668 bytes) 2011-01-27 10:15


png file icon bug3.png [^] (8,859 bytes) 2011-01-27 10:15


zip file icon test191_backup_27.01.2011.zip [^] (58,903 bytes) 2011-01-27 13:17
png file icon Assingned TC issue.PNG [^] (19,374 bytes) 2011-03-28 16:43

- Relationships
duplicate of 0004203closedasimon Test case become unassigned on a build when it is unassigned from another build 

-  Notes
(0013120)
fman (administrator)
2010-12-28 15:17

not enough info
(0013122)
terryzuo (reporter)
2010-12-29 01:11

I'm not sure the reproduce steps as this only exists in this build.
The steps listed as below:
1.copy the assignments when I created the 1216 build
2.change the "assigned to" for some cases
(0013124)
fman (administrator)
2010-12-29 08:05

without your DB we can not do a try. Sorry
(0013134)
terryzuo (reporter)
2010-12-30 02:39

The DB used in our group is so big.I tried to the export DB via SQL file,which is more than 40M.
How can I put the related data to here.
This issue dose exist only when you changed the assigned status with different platforms somehow.
(0013446)
goosetea1 (reporter)
2011-01-27 10:14

I just had the same issue
1. I had two builds with 85 Test Cases
2. In new build I added 6 cases and reassigned 9 my cases to other tester
3. Now I have in first two builds 76 assigned cases. That is those 9 cases were deducted from 85 assigned.

And the current build shows 109 instead of 91 (85+6 added) actual assigned cases. Looks like 85 was summed with 9 and then with 9 again for two previous builds. and it is not only assigned cases values that were ruined.

It is very easy to reproduce without DB dump.
1. Create project
2. Create test plan
3. Create test build 1.0
4. Create 3 cases
5. Assign 1 case to someone and 2 for yourself.
6. Fail one of your cases
7. Close the build
8. Create build 2.0
9. Assign not run case of yours to other tester
Stats in Report are ruined! Now you have 4 cases assigned while there are 3 actual cases and 3 not run while you have run and failed 1 and stats in test suite are correct
(0013451)
fman (administrator)
2011-01-27 11:36

Please upgrade to 1.9.1 and retest.
if problem persist provide us your db to do tests
(0013457)
goosetea1 (reporter)
2011-01-27 12:10

I accessed report from 1.9.1 it shows same data with wrong stats (i have not patched db for 1.9.1, because i only accessed report to view stats and didn't change anything)

maybe it will not create the same problem if i will do everything from the start in 1.9.1 ( i can verify it only in the evening)

but i think we need some resolution for the data as it is now. I guess you only calculate data on this page and do not store general plan stats?
(0013458)
goosetea1 (reporter)
2011-01-27 13:18

i uploaded a dump with test project created in 1.9.1
same issues
login as kosta/kosta2
(0013460)
goosetea1 (reporter)
2011-01-27 14:33

@terryzuo
I found a temporary solution for our problem
if you go to assign test case execution page and select old builds you can see unaasigned test cases (assignment was taken from them and set yours previous assignments back) this will fix stats but in your case you have too much cases i guess
(0013595)
terryzuo (reporter)
2011-02-11 05:19

@goosetea1:
Got it! Thanks.
(0013600)
fman (administrator)
2011-02-12 14:15

Reminder sent to: Julian

Think you or Andreas are the guys for this. can you give a look when you will have time ?
(0014212)
JP (reporter)
2011-03-22 19:17

I see this problem too. Am using 1.9.1

To get around it, I had "copied assignments" from the very first build and then assigned the unassigned test cases to get the correct Assigned number on the Overall Status.

But I am back to the wrong number by simply reassigning test case from one tester to another. I frequently reassign test cases to load balance. I have 530 test cases in the test plan but due to all the reassigning my total Assigned shows 710.
(0014311)
Julian (reporter)
2011-03-27 18:22

i think this is a duplicate of 0004203 and should be fixed with TL 1.9.2
(0014312)
Julian (reporter)
2011-03-28 06:53

could you please check if this is resolved with Testlink 1.9.2 ?
(0014313)
Julian (reporter)
2011-03-28 08:13

I was not able to reproduce with the steps you provided.
If you dont give further feedback i will resolve issue soon.
(0014327)
JP (reporter)
2011-03-28 16:43

Julian, I'll try the fix posted in 0004203 however it seems to be about unassigned TCs.

The problem I see (and what I believe the original reporter Terry reports) is with reassigning test cases. What I think is happening is when we reassign test cases, they get counted twice (original assignment and new assignment). So # of "Assigned test cases by build" on the "General Test Plan Metrics" increases beyond actual test cases in the test plan hence messing up the stats royally.

Take a look at the snippet of the report attached ("Assigned TC issue"). I have added an Overall Test Plan status just above the build status. As of build #36749, we have had 539 TCs in the test plan. But you'll notice due to reassignments, the total shows over 630. Then in build 37005, I did assignments from scratch again and it happily started out with 539 but as soon as I did some reassignments, it got to 578. In build 37218, lots of reassignments led to the count of 880. I just added a new build (37498) and was too lazy to reassign from scratch and copied assignments so new build 37498 matches 37218 (until I reassign again). All this while the very top line shows the Overall Status by test Plan which indicates I only have 539 TC in the test plan.

Sorry about the length of the description, but I hope this clarifies the problem.
(0014329)
Julian (reporter)
2011-03-28 18:49

let me know when you tested the fix.
(0014400)
JP (reporter)
2011-04-01 17:37

I applied the fix from 0004203 and it appears to have worked. I do not see the Assigned count increase every time TC is reassigned. Real test will be when we setup a new test plan and it stays consistent.

Thank you all for the fix.
(0014402)
Julian (reporter)
2011-04-01 18:20

Thanks for the feedback!

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2010-12-28 05:59 terryzuo New Issue
2010-12-28 05:59 terryzuo File Added: 12-28-2010 1-51-58 PM.png
2010-12-28 15:17 fman Note Added: 0013120
2010-12-29 01:11 terryzuo Note Added: 0013122
2010-12-29 08:05 fman Note Added: 0013124
2010-12-30 02:39 terryzuo Note Added: 0013134
2011-01-27 10:14 goosetea1 Note Added: 0013446
2011-01-27 10:15 goosetea1 File Added: bug2.png
2011-01-27 10:15 goosetea1 File Added: bug3.png
2011-01-27 11:36 fman Note Added: 0013451
2011-01-27 11:36 fman Assigned To => fman
2011-01-27 11:36 fman Status new => feedback
2011-01-27 12:10 goosetea1 Note Added: 0013457
2011-01-27 13:17 goosetea1 File Added: test191_backup_27.01.2011.zip
2011-01-27 13:18 goosetea1 Note Added: 0013458
2011-01-27 14:33 goosetea1 Note Added: 0013460
2011-02-11 05:19 terryzuo Note Added: 0013595
2011-02-11 05:19 terryzuo Status feedback => assigned
2011-02-12 14:15 fman Note Added: 0013600
2011-03-22 19:17 JP Note Added: 0014212
2011-03-27 18:22 Julian Note Added: 0014311
2011-03-28 06:53 Julian Note Added: 0014312
2011-03-28 06:53 Julian Status assigned => feedback
2011-03-28 08:13 Julian Note Added: 0014313
2011-03-28 16:43 JP Note Added: 0014327
2011-03-28 16:43 JP File Added: Assingned TC issue.PNG
2011-03-28 18:49 Julian Note Added: 0014329
2011-04-01 17:37 JP Note Added: 0014400
2011-04-01 18:19 Julian Relationship added duplicate of 0004203
2011-04-01 18:19 Julian Status feedback => resolved
2011-04-01 18:19 Julian Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-04-01 18:19 Julian Resolution open => fixed
2011-04-01 18:20 Julian Note Added: 0014402
2011-04-01 18:20 Julian Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker