Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004125TestLinkReportspublic2010-12-23 19:582011-07-02 13:48
Reporteraostad 
Assigned ToEloff 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWin7OS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004125: Filtering does not work in " Test result matrix"
DescriptionExcept for the "Test Case" column, the filtering does not work for other columns.
Please look at the attached screenshots.
Steps To Reproduce1- Go to Report
2- Select "Test Result Matrix"
3- Try to filter the test result by "Failed" or "Pass", etc.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
BrowserIE8/FF
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon TestLink-error-filtering in Test Result Matrix-01.png [^] (40,749 bytes) 2010-12-23 19:58


png file icon TestLink-error-filtering in Test Result Matrix-02.png [^] (52,950 bytes) 2010-12-23 19:58


png file icon TestLink-error-filtering in Test Result Matrix-03.png [^] (54,556 bytes) 2010-12-23 19:59


xml file icon Filtering-issue.xml [^] (4,019 bytes) 2010-12-23 21:04

- Relationships
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0013085)
fman (administrator)
2010-12-23 20:03

Give a more details

how many builds ?
there are platform ?
attach db or XML file in order to reproduce
(0013087)
aostad (reporter)
2010-12-23 20:07

4 Builds.
No Platform defined.
(0013090)
aostad (reporter)
2010-12-23 21:05

A file has been attached. It was generated from a temporary project to help you reproduce the issue.
(0013096)
Julian (reporter)
2010-12-23 22:38

call it a known issue.

filters need some more care and refactoring of current code.

target: 2.0
(0013887)
Julian (reporter)
2011-03-17 10:34
edited on: 2011-03-17 10:46

Reminder sent to: Eloff

Erik, this error is caused because you store an array for execution result fields.

Example from resultsTC.php:

$resultsForBuild = array(
"value" => $resultsCfg['status_code']['not_run'],
"text" => $exec_link . $resultsForBuildText,
"cssClass" => $cssClass);

on source code this looks like that:
{"value":"f","text":"Failed","cssClass":"failed_text"}

-> filtering does not work

any solution?

statusRenderer makes it "readable" for HTML but filters seem to work with tabledata.

(0014064)
Eloff (reporter)
2011-03-19 16:16

Ok. I guess it is possible to hint the filter function where to look for "filterable" data. I hope I get time to fix this tomorrow
(0014202)
Eloff (reporter)
2011-03-21 22:15

Fixed in git
http://gitorious.org/testlink-ga/testlink-code/commit/d25b74d8707ac0436c5b15d9ecf629ffc47f25ec [^]
(0015415)
fman (administrator)
2011-07-02 13:48

1.9.3 released

- Issue History
Date Modified Username Field Change
2010-12-23 19:58 aostad New Issue
2010-12-23 19:58 aostad File Added: TestLink-error-filtering in Test Result Matrix-01.png
2010-12-23 19:58 aostad File Added: TestLink-error-filtering in Test Result Matrix-02.png
2010-12-23 19:59 aostad File Added: TestLink-error-filtering in Test Result Matrix-03.png
2010-12-23 20:03 fman Note Added: 0013085
2010-12-23 20:07 aostad Note Added: 0013087
2010-12-23 21:04 aostad File Added: Filtering-issue.xml
2010-12-23 21:05 aostad Note Added: 0013090
2010-12-23 22:38 Julian Note Added: 0013096
2011-03-17 10:34 Julian Note Added: 0013887
2011-03-17 10:34 Julian Assigned To => Eloff
2011-03-17 10:34 Julian Status new => assigned
2011-03-17 10:46 Julian Note Edited: 0013887 View Revisions
2011-03-19 16:16 Eloff Note Added: 0014064
2011-03-21 22:15 Eloff Note Added: 0014202
2011-03-21 22:15 Eloff Status assigned => resolved
2011-03-21 22:15 Eloff Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-03-21 22:15 Eloff Resolution open => fixed
2011-03-22 22:39 Eloff Relationship added child of 0004337
2011-07-02 13:48 fman Note Added: 0015415
2011-07-02 13:48 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker