Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004115TestLinkTest Specificationpublic2010-12-21 11:302011-01-22 15:11
Reporteramitkhullar 
Assigned Toamitkhullar 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004115: Custom Field Filters in Test case specs dont work in a corner condition
DescriptionIn the Test Spec page open a test cases and
set Custom Field A = Yes and and B = Yes

Goto the Test Spec filter now on left page and set the same value in custom field filter for the fields A/B to search the test case. Nothing is returned.
Steps To ReproduceCreate 2 Custom Fields A and B
of Type Radio Button
Available for Test Case
with Possible Values Yes | No and
assign it to Test Spec Design and
display on test exec
Additional InformationThis is because of the incorrect fetching function from db
on line 1549 on treemenu.inc.php
It is
$rows = $db->fetchRowsIntoMap($sql,'value');
and should be
$rows = $db->fetchColumnsIntoArray($sql,'value');

Same thing goes in testplan.class.php at line 2860 also.
TagsNo tags attached.
Database (MySQL,Postgres,etc)1.9
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0003995closedamitkhullar Custom Field Filters in Test case Execution : Dont Work 
related to 0004024closedamitkhullar Add Test Case to Test Plan gives sql error on filtering the test cases on custom field value 
parent of 0004039closed Availables Fixes for 1.9.0 (Prague) 
related to 0004087closedamitkhullar Filtering Test Cases by more than one custom field gives zero results 

-  Notes
(0013053)
amitkhullar (reporter)
2010-12-21 12:11

Fixed in 1.9.1 and head
(0013385)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-21 11:30 amitkhullar New Issue
2010-12-21 11:30 amitkhullar Status new => assigned
2010-12-21 11:30 amitkhullar Assigned To => amitkhullar
2010-12-21 11:32 amitkhullar Relationship added parent of 0004039
2010-12-21 11:32 amitkhullar Relationship added related to 0003995
2010-12-21 11:33 amitkhullar Relationship added related to 0004024
2010-12-21 12:11 amitkhullar Note Added: 0013053
2010-12-21 12:11 amitkhullar Status assigned => resolved
2010-12-21 12:11 amitkhullar Fixed in Version => 1.9.1 (bug fixing)
2010-12-21 12:11 amitkhullar Resolution open => fixed
2011-01-05 04:58 amitkhullar Relationship added related to 0004087
2011-01-22 15:11 fman Note Added: 0013385
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker