Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004112TestLinkReportspublic2010-12-20 14:082011-01-22 15:11
Reporterallanbj 
Assigned Tofman 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformIIS7OSWindowsOS Version2008 R2
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004112: IIS/MSSQL: Report "Test Cases with Execution Details" fails with an "Internal server error"
DescriptionThe report "Test Cases with Execution Details" fails every time with a "500 Internal server error".

I enclose my php.ini because a problem with a warning caused by navbar.php (line 96) was fixed by changing some reporting settings in php.ini - and this could be related because the error reported by the IIS is the same.
Steps To ReproduceGo to reports -> Test Cases with Execution Details. After a short time the internal server error appears every time.
Additional InformationFrom the Windows event log:

"Faulting application name: php-cgi.exe, version: 5.2.14.14, time stamp: 0x4c47484c
Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5bdb3b
...
Faulting application path: c:\php\php-cgi.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll"
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL v10.50.1600 Enterprise
BrowserAll
PHP Version5.2.14
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon php.ini [^] (50,703 bytes) 2010-12-20 14:08

- Relationships

-  Notes
(0013311)
oileanach (reporter)
2011-01-18 10:09

I am also seeing this bug in my environment. My environment is

Win Server 2003
MSSQL 2008
(Apache & PHP) XAMPP 1.7.3
(0013312)
fman (administrator)
2011-01-18 10:55

data needed

  1. amount of test projects
  2. amount of test cases
  3. amount of test plans
  4. amount of builds


For the tesplan with problems

  1. amount of test cases
  2. amount of builds
  3. amount of executions
(0013314)
oileanach (reporter)
2011-01-18 11:18

In my case it doesnt seem to matter what size project it is.

In the current setup...

1. 6 projects (p1: 2 x tc, p2: 73 x tc, p3: 127 x tc, p4: 96 x tc, p5: 5 x tc, p6: 235 x tc)
2. 535(ish) test cases
3. 10 test plans
6. 7 builds

Test plan with problems (it happens for me in each project but here are details of smallest project)
1. 2 test cases
2. 1 build
3. 2 executions
(0013315)
allanbj (reporter)
2011-01-18 12:38

To answer your question the size of the project has no influence on the error. It can be reproduced with just one project, one plan, execution of one test case with just one step. Or as one of my colleagues did it with a hundred or more test cases. Allow me to elaborate...

In my company we started using TestLink at v1.8.5 on Apache/Mysql but wanted to convert to IIS/MSSQL because of company policy and backup options. So we had v1.8.5 Apache, v1.9 Apache and V1.9 IIS installations running at the same time to test the new version and platform (compared to v1.8.5 on Apache in production).

Apache v1.9 runs perfectly but unfortunately the IIS/MSSQL setup has proven to be nothing but trouble due to the reported and other issues (including an issue that oileanach has reported elsewhere that wasn't reproducable outside an IIS/MSSQL environment). One of these issues (also IIS/MSSQL only) is that we saved a table pasted from MSWord (9.2k html data) into a test case summary, saved it but on retrieval only half was displayed and the rest was ignored. I checked in the database where I found the full text. This was also reproduced with plain text and I really should have checked if this was a known error and reported it if it wasn't. I'm sorry I didn't fill out a report.

In any case our conclusion has been to go back to the 'original' Apache/Mysql environment (upgrading to v1.9) as the code seems to function best in this environment. At least that is what my experience tells me no matter if IIS, MSSQL, PHP or the combination of all three is the root cause. If you have the time, I would suggest testing extensively using these three components.
Thanks for looking into this matter in any case,
Allan Bjerrum
Fan of TestLink and looking forward to the test case review feature :)
(0013319)
fman (administrator)
2011-01-18 21:11

issue is created by use of reserved keyword EXEC as table alias in
class: cfield_mgr.class.php
method: get_linked_cfields_at_execution

if you change it to any other thing (example EXECU) all will work again (at least on my tests)

In addition please do following steps if no done yet

1. post your company on forum
2. go to sourceforge TL summary section and add a 'Thumb up'
3. go to jumpox site section user voice and vote for a jumpbox with TL


Please do not chanhe aim of issue -> this comment will have no effect at all:
>> looking forward to the test case review feature :)
if you would like to see this feature look for the right issue (if exists) or open a new one.
(0013351)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-20 14:08 allanbj New Issue
2010-12-20 14:08 allanbj File Added: php.ini
2011-01-18 10:09 oileanach Note Added: 0013311
2011-01-18 10:55 fman Note Added: 0013312
2011-01-18 11:18 oileanach Note Added: 0013314
2011-01-18 12:38 allanbj Note Added: 0013315
2011-01-18 21:05 fman Assigned To => fman
2011-01-18 21:05 fman Status new => assigned
2011-01-18 21:11 fman Note Added: 0013319
2011-01-18 21:22 fman Status assigned => resolved
2011-01-18 21:22 fman Fixed in Version => 1.9.1 (bug fixing)
2011-01-18 21:22 fman Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013351
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker