Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004100TestLinkRequirement Managementpublic2010-12-14 13:162011-01-22 15:11
Reportertlbull.tester 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004100: Import Requirements - create new version for duplicate requirements
DescriptionThere are 2 actions proposed for duplicate requirements:
- update data on latest version, or
- create a new version.

If you choose the option, create a new vesion, a new version is created for the duplicate requirement but the modified
data are not updated (if the description of requirement has been changed, the description field isn't updated).
Steps To ReproduceRequirements Specification module
- Import an xml file containing the requirements
- modify the description field for a requirement in the input file
- import the modified file choosing the option "create a new version" for
duplicate requirements (same docId or same title)

Result: a new version is created for modified requirement, but the description of the requirement is not updated

Expected result: a new version is created for modified requirement with the description field of the requirement updated


TagsNo tags attached.
Database (MySQL,Postgres,etc)MySql 5.067
BrowserFirefox 3.6.13
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesxml file icon Les Exigences Produit-req-specUpd.xml [^] (11,864 bytes) 2010-12-15 09:13
xml file icon Les Exigences Produit-BR1.xml [^] (1,467 bytes) 2010-12-15 09:14
gif file icon TL_ScreenShot011.GIF [^] (132,113 bytes) 2010-12-15 09:20


zip file icon fix-4100.zip [^] (19,977 bytes) 2010-12-18 11:33
xml file icon Les Exigences Produit-BR1-title.xml [^] (1,454 bytes) 2011-01-07 15:28

- Relationships
child of 0004039closed Availables Fixes for 1.9.0 (Prague) 

-  Notes
(0012981)
fman (administrator)
2010-12-14 20:27

Attach files you are using
(0012989)
tlbull.tester (reporter)
2010-12-15 09:25

- first file imported: Les Exigences Produit-req-specUpd.xml
- second import:Les Exigences Produit-BR1.xml
- selected options for duplicate requirements:
- same id
- create new version

also TestLink conformation for import: TL_screenShot,
but title and description fields are not updated
(0013035)
fman (administrator)
2010-12-18 11:36

apply attached fix, retest and let us know.

If everything is ok, check:
1. do you have added your company on www.teamst.org Forum ?
2. go to sourceforge and add 'thumb up' on testlink summary
3. go to jumpbox site and vote for a jumbox virtual machine with TL be created.
(0013171)
fman (administrator)
2011-01-05 19:36

no more user feedback
(0013203)
tlbull.tester (reporter)
2011-01-07 14:44
edited on: 2011-01-08 11:08

Sorry about the answer in late.
After some tests there are still some issues on this bug.
Using the scenario described in "Steps to reproduce section", and selecting the option "Create new version" for the requirements having the same DOCId
 - a new version is created for the requirement,
 - the "title" field is updated
 - but the "description" field of the requirement isn't updated.
 
Also, for the second option: "Create new version" for the requirements having the same title,
a new version is created but the "DOCId" and "description" fields are not updated.

(0013204)
tlbull.tester (reporter)
2011-01-07 15:29

In attach. the file used to test this second option (Les Exigences Produit-BR1-title.xml).
(0013215)
fman (administrator)
2011-01-08 11:16
edited on: 2011-01-08 11:20

Important thing:
at least with current version when you try to import linking BY TITLE,
changing DOCID while creating a NEW version is NOT ALLOWED, because ALL REQ versions have to have SAME DOCID (DOCID is REQ IDENTITY).
System will proceed in same way when you request to create a NEW VERSION on GUI ->
you can not change anything till you enter EDIT mode.
We consider this the safer approach to use.


I will attach a new version of fix.
Last XML you have uploaded contains a REQ not present on previous xml => importing it create REQ-BR-147 and can not update anything

(0013350)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-14 13:16 tlbull.tester New Issue
2010-12-14 20:27 fman Note Added: 0012981
2010-12-15 09:13 tlbull.tester File Added: Les Exigences Produit-req-specUpd.xml
2010-12-15 09:14 tlbull.tester File Added: Les Exigences Produit-BR1.xml
2010-12-15 09:20 tlbull.tester File Added: TL_ScreenShot011.GIF
2010-12-15 09:25 tlbull.tester Note Added: 0012989
2010-12-18 11:33 fman File Added: fix-4100.zip
2010-12-18 11:36 fman Note Added: 0013035
2010-12-18 11:36 fman Assigned To => fman
2010-12-18 11:36 fman Status new => feedback
2010-12-18 11:40 fman Relationship added child of 0004039
2011-01-05 19:36 fman Note Added: 0013171
2011-01-05 19:36 fman Status feedback => resolved
2011-01-05 19:36 fman Fixed in Version => 1.9.1 (bug fixing)
2011-01-05 19:36 fman Resolution open => fixed
2011-01-07 14:44 tlbull.tester Note Added: 0013203
2011-01-07 14:44 tlbull.tester Status resolved => assigned
2011-01-07 14:44 tlbull.tester Resolution fixed => reopened
2011-01-07 15:28 tlbull.tester File Added: Les Exigences Produit-BR1-title.xml
2011-01-07 15:29 tlbull.tester Note Added: 0013204
2011-01-08 11:08 fman Note Edited: 0013203 View Revisions
2011-01-08 11:08 fman Note Edited: 0013203 View Revisions
2011-01-08 11:16 fman Note Added: 0013215
2011-01-08 11:20 fman Note Edited: 0013215 View Revisions
2011-01-18 21:25 fman Status assigned => resolved
2011-01-18 21:25 fman Resolution reopened => fixed
2011-01-22 15:11 fman Note Added: 0013350
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker