Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004097TestLinkTest Plan (builds, milestones, test assign)public2010-12-13 21:422011-01-22 15:11
Reporterbizob28 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLAMPOSFedoraOS Version11
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004097: Test case assign crashes browser
DescriptionI've found that assigning test cases is taking so long or it crashes the browser during all the .js executions. My scenario is I have 5 platforms, I want to assign 500 test cases from 7 different test suites. It appears to load all the test cases without ext applied to each test suite, it then loads all the test cases in ext which is taking forever and usually crashing Firefox.
Steps To Reproduce 1. Create a test plan that contains 5 platforms
 2. Add 500+ test cases from 7+ different test suites
 3. Click assign test case execution
 4. Click the root of all suites so it loads all 500 test cases in right pane
 5. Select a platform click Do
 6. Select a user click Do
 7. click Save

expected results
 1. the test cases are assigned to user and browser is available for other action

actual result
 1. it takes so long for the list to reload into ext that it usually crashes firefox
Additional InformationTo me, I really don't care if the test case assignment screen loads the test cases into the ext tables. That's what is taking so long to generate that this tool right now is unusable to me.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.4
BrowserChrome & Firefox
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0012963)
bizob28 (reporter)
2010-12-13 21:46

I want to change this severity for crash but cannot do so
(0012992)
fman (administrator)
2010-12-15 09:53

provide DB sample please
Attach here or send to francisco.mancardi@gmail.com
(0012996)
Julian (reporter)
2010-12-15 13:45
edited on: 2010-12-15 14:10

>> Additional Information:
>> To me, I really don't care if the test case assignment screen loads the test >> cases into the ext tables. That's what is taking so long to generate that
>> this tool right now is unusable to me.

... this is no additional information - this is a feeling and is absolute irrelevant for this issue.

how did you find out that exttable conversion is the problem and not the huge amount of data that has to be written to database?

before calling this a major/crash issue we should think about a real use case for this scenario. you assign 3500+ test cases to 1 user in 1 step. i doubt this is or should be common practice.

(0012997)
bizob28 (reporter)
2010-12-15 14:17
edited on: 2010-12-15 14:22

I'm not trying to assign 3,500+ test cases to one user. I'm trying to assign 500 test cases to one user but I have 5 different platform assigned to the test plan. However, in the past we have been assigning 2,000+ test cases to a user with no problem in the past. I haven't had time to triage this on my own as we are in the middle of testing a major release of our software and have no time to do so. I think the ideal situation would be an configuration option to turn on/off the exttable

(0012998)
Julian (reporter)
2010-12-15 14:34

that this is very common for your organization is not a use case.

please describe a reasonable scenario. i cannot think of a scenario that requires to assign 3500 test cases for 5 platforms => 17500 test exeuctions are assigned with 1 click to 1 user.

many environment related thing are influencing this issue:
- php configuration
- your machines hardware
- OS
- ...
(0012999)
bizob28 (reporter)
2010-12-15 14:48

As I said in my previous comment, I've never mentioned the number 3,500. I have 500 test cases that need one user to be assigned per platform. There are 7 platforms. To do so,

Assumption: 500 test cases and 7 platforms have been assigned to the test plan
  1. Select current test plan
  2. Click Assign Test Case Execution
  3. Select the top level test suite that contains all 500 test cases(Below the top level suite contain(3 lower levels of test suites ranging from 4-6 per level)
  4. Select a Platform, click Do
  5. Select a user, click Do
  6. Click Save
  7. Select same platform, click Do to uncheck previous platform
  8. Select a new platform, click Do
  9. Select a user, click Do
 10. Click Save

Repeat until all 7 platforms have user assigned.

Note: The slowdown I see is after save, as I mentioned before it loads the list of test cases, then reloads the same list in ext.
(0013006)
fman (administrator)
2010-12-15 21:19

go to tc_exec_assignment.tpl

and comment

// 20100927 - franciscom
// Ext.onReady(function()
// {
// // create the grid
// var idx=0;
// var gridSet = new Array();
// for(idx=1; idx <= loop2do; idx++)
// {
// gridSet[idx] = new Ext.ux.grid.TableGrid("the-table-"+idx, {
// stripeRows: true // stripe alternate rows
// });
// gridSet[idx].render();
// }
// });

CLEAN directory template_c and retest

let us know
(0013015)
Julian (reporter)
2010-12-16 18:57

we are waiting for your feedback...
(0013020)
bizob28 (reporter)
2010-12-16 20:41

Thanks for the possible fix, I will validate this tomorrow and get back to you
(0013058)
bizob28 (reporter)
2010-12-21 18:19

this fix seems to be working, however i did log a bug today, not sure if it is a result of this: http://mantis.testlink.org/view.php?id=4117 [^]
(0013384)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-13 21:42 bizob28 New Issue
2010-12-13 21:46 bizob28 Note Added: 0012963
2010-12-15 09:53 fman Note Added: 0012992
2010-12-15 13:45 Julian Note Added: 0012996
2010-12-15 14:10 fman Note Edited: 0012996 View Revisions
2010-12-15 14:17 bizob28 Note Added: 0012997
2010-12-15 14:22 bizob28 Note Edited: 0012997 View Revisions
2010-12-15 14:34 Julian Note Added: 0012998
2010-12-15 14:48 bizob28 Note Added: 0012999
2010-12-15 21:19 fman Note Added: 0013006
2010-12-16 18:57 Julian Note Added: 0013015
2010-12-16 18:57 Julian Assigned To => fman
2010-12-16 18:57 Julian Status new => feedback
2010-12-16 20:41 bizob28 Note Added: 0013020
2010-12-16 20:41 bizob28 Status feedback => assigned
2010-12-21 18:19 bizob28 Note Added: 0013058
2010-12-21 19:32 fman Status assigned => resolved
2010-12-21 19:32 fman Fixed in Version => 1.9.1 (bug fixing)
2010-12-21 19:32 fman Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013384
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker