Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004096TestLinkRequirement Managementpublic2010-12-13 14:452014-12-31 14:22
Reporterspacomp 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.13 (2015 #1) 
Summary0004096: Supplementing Hyperlink to inlined Images in a Requirement Specification Document
DescriptionHi All,

We have recently got upgraded to TestLink 1.9.0 - Its a great tool to work with.


We have a following scenario of working on a Test Cases where in the input documents are in the form of

1. Menu Tree - a Sequence of Screen Transitions which are expected on a particular events
2. SRS/SDS/SAS - all pertaining to a detailed description about the application behavior for different level of users.

Now when I create a Test Case out of these input document, I need to incorporate a relevant Screen Shot to supplement the necessary part. We have a concern if we are to go ahead and include the images as a in lined content under following scenario,

Scenario 1: Supposing if a customer wishes to change the screen transitions, we would be required to identify the Test Cases where all we had included the images and need to replace with the New Version of test cases. Test Link has a great feature of incorporating the images into the running text description.

Workaround Expected: It would be of great help if the user could provide a link to a specific screen shot which will always point to a image by its name and the same is loaded when user generates a Test Specification document either in HTML /WORD format.

Ex. For a Test Case version 1.0 the Login Screen was say "Login Screen.JPG"

a change in the Login Screen should be entailed by mere overwriting of new Login Screen onto the OLD screen as the name would remain same and HYPERLINK shall load the latest image onto a new version of Test Cases.

Hope Moderators could give it a thought.

Happy TestLink User :)

TagsIMAGES ON REPORTS
Database (MySQL,Postgres,etc)My SQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesdocx file icon Sample Test Case.docx [^] (14,098 bytes) 2010-12-14 07:06
docx file icon Test Case in EDIT MODE.docx [^] (14,098 bytes) 2010-12-14 07:16
docx file icon Test Specification Document.docx [^] (70,775 bytes) 2010-12-14 07:16

- Relationships
duplicate of 0004036closedfman Not display attachment image in word format 
has duplicate 0004101closedfman Images not loaded with word format of Test Specification Document 

-  Notes
(0012958)
Julian (reporter)
2010-12-13 16:18

describe your requests more clearly , shorter and leave out technical jargon.
(0012965)
spacomp (reporter)
2010-12-14 03:57

The requirement is all about, inlining a HYPERLINK to a uploaded image which is a part of SRS rather than including a image itself.

But while generating a Test Specification Document, the image should come as a inlined [actual image and not hyperlink this time]

Hope its clear this time, JULIAN?
(0012966)
Julian (reporter)
2010-12-14 06:46
edited on: 2010-12-14 06:52

no need for capitalizing me.

why dont you explain step by step what you do.

for example:

1. create test case
2. insert image on summary via fckeditor
3. generate test specification report in format HTML/Writer/Word

current behaviour: instead of images only html code is shown
expected behaviour: images are shown

is this what you want ?!

and in addition you are just creating confusion here:
title: Supplementing Hyperlink to inlined Images in a Requirement Specification Document
last comment: But while generating a Test Specification Document, the image should

1. Menu Tree - a Sequence of Screen Transitions which are expected on a particular events
2. SRS/SDS/SAS - all pertaining to a detailed description about the application behavior for different level of users.
... at least you gave us this vital information - even though i do not understand a word.

is it really so hard to take some minutes to describe an issue in a way that allows others to understand it ?

(0012967)
spacomp (reporter)
2010-12-14 07:06
edited on: 2010-12-14 07:17

Sorry, don't feel bad for having capitalized. I just wanted to convey you what we are looking out for.

First of all I would like to call this a REQUEST FOR NEW FEATURE rather than treating this as a BUG/ISSUE

Please find the attached sample test case "Sample Test Case.docx"

Steps are as follows:

1. Select Create Requirement
2. Edit necessary part.
3. While substituting a necessary image into the Description / Expected Results section, the user should get the HYPERLINK with a customized TITLE as shown in the document

Please have a look into the document attached "Test Case in EDIT MODE.docx" more details on this.

4. When user generates a Test Specification Document, these HYPERLINKS should be replaced with the actual images [IF POSSIBLE], check the "Test Specification Document.docx"

Hope, I have not created any confusion here again.

(0012968)
Julian (reporter)
2010-12-14 09:08

is this the same problem: 0004036 ?
(0012969)
spacomp (reporter)
2010-12-14 09:49
edited on: 2010-12-14 09:49

What I was expecting was an enhancement with the feature.

Yes, there is an issue with including the images when we generate a Test Specification Document in WORD FORMAT as posted with issue ID "0004036".

Please let me know the necessary changes to be made to overcome the problem as mentioned in the issue ID 0004036

Thanks in advance.

(0013882)
wwyyuen (reporter)
2011-03-16 22:23

Hi, first post on this system...

I think two issues are raised here:
1. BUG - the linked images do not always have the right URL - there's a workaround posted in 2721

2. FEATURE REQUEST - ideally the images should not be linked, they should be embedded (or maybe this should be an option?), so that people who may not have access to the TestLink server (which hosts the images) can still see a fully readable word document

Does that make sense? Thanks!
(0013883)
wwyyuen (reporter)
2011-03-16 22:25
edited on: 2011-03-16 22:26

Oh sorry, forgot to mention the work around for problem 2. If anyone is urgent, you can manually convert the linked images to embedded within Microsoft Word. Go to Edit -> Links.. break the links for all the images, then save the document.

(0013888)
Julian (reporter)
2011-03-17 10:40

Reminder sent to: amitkhullar, asimon, fman

Do you know if it is possible to embed images within generated document?

If not we should document workaround mentioned in comment 0013883 on this page and resolve those issues as won't fix.

- Issue History
Date Modified Username Field Change
2010-12-13 14:45 spacomp New Issue
2010-12-13 16:18 Julian Note Added: 0012958
2010-12-13 20:42 fman Priority high => normal
2010-12-14 03:57 spacomp Note Added: 0012965
2010-12-14 06:46 Julian Note Added: 0012966
2010-12-14 06:52 Julian Note Edited: 0012966 View Revisions
2010-12-14 07:06 spacomp Note Added: 0012967
2010-12-14 07:06 spacomp File Added: Sample Test Case.docx
2010-12-14 07:07 spacomp Note Edited: 0012967 View Revisions
2010-12-14 07:07 spacomp Note Edited: 0012967 View Revisions
2010-12-14 07:16 spacomp File Added: Test Case in EDIT MODE.docx
2010-12-14 07:16 spacomp File Added: Test Specification Document.docx
2010-12-14 07:17 spacomp Note Edited: 0012967 View Revisions
2010-12-14 09:08 Julian Note Added: 0012968
2010-12-14 09:49 spacomp Note Added: 0012969
2010-12-14 09:49 spacomp Note Edited: 0012969 View Revisions
2010-12-14 19:06 Julian Relationship added duplicate of 0004036
2010-12-15 06:25 Julian Relationship added has duplicate 0004101
2011-03-16 22:23 wwyyuen Note Added: 0013882
2011-03-16 22:25 wwyyuen Note Added: 0013883
2011-03-16 22:26 wwyyuen Note Edited: 0013883 View Revisions
2011-03-17 10:40 Julian Note Added: 0013888
2014-10-18 17:25 fman Tag Attached: IMAGES ON REPORTS
2014-10-18 17:25 fman QA Team - Task Workflow Status => READY FOR TESTING
2014-10-18 17:25 fman Status new => resolved
2014-10-18 17:25 fman Fixed in Version => 1.9.13 (2015 #1)
2014-10-18 17:25 fman Resolution open => fixed
2014-10-18 17:25 fman Assigned To => fman
2014-12-31 14:22 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker