Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004087TestLinkCustom fieldspublic2010-12-09 15:012011-01-22 15:11
Reporterpkucka 
Assigned Toamitkhullar 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSXP SP3OS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004087: Filtering Test Cases by more than one custom field gives zero results
DescriptionFiltering by Custom Fields doesn't show expected results when more than one custom field is used for filtering. It should use AND logic between all selections.
Steps To Reproduce1.Create two test cases, Case1 and Case2
2.Create two custom fields, cf1 and cf2, for both custom fields do:
  a.Select available for Test Case,
  b.Type of custom field - list,
  c.Possible values for cf1 1|2|3, for cf2 a|b|c
3.Assign both custom fields for your active Test Project
4.Go to Test Specification tab
5.Edit Case1, define cf1 as “1” and cf2 as “a”
6.Edit Case2, define cf1 as “2” and cf2 as “b”
7.In Filters window select “1” for cf1 then hit Apply
8. After applying the filter Case1 will be displayed on the tree as expected
9. Reset Filters.
10. In filters window select “1” for cf1 and “a” for cf2 and hit Apply
11. There is zero test cases found for this filtering which is wrong, case1 should be displayed as result of filtering
Additional InformationI have tried it with type of custom fields defined as string and radio and mixture of those two, it has always returned zero results
TagsCustom Fields, Filters
Database (MySQL,Postgres,etc)mysql 5.1.37
BrowserIE, mozilla, chrome
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0004024closedamitkhullar Add Test Case to Test Plan gives sql error on filtering the test cases on custom field value 
related to 0003995closedamitkhullar Custom Field Filters in Test case Execution : Dont Work 
related to 0004115closedamitkhullar Custom Field Filters in Test case specs dont work in a corner condition 

-  Notes
(0012933)
amitkhullar (reporter)
2010-12-10 10:29

This is a known issue, please search the mantis before raising issues to avoid duplication.
(0012934)
amitkhullar (reporter)
2010-12-10 10:32

This has been fixed in 1.9.1 and wud be available in next release.
(0013151)
fman (administrator)
2011-01-04 20:21

use fixes available on related issues
(0013376)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-09 15:01 pkucka New Issue
2010-12-10 09:10 pkucka Tag Attached: Custom Fields
2010-12-10 09:10 pkucka Tag Attached: Filters
2010-12-10 10:29 amitkhullar Note Added: 0012933
2010-12-10 10:31 amitkhullar Relationship added duplicate of 0004024
2010-12-10 10:32 amitkhullar Note Added: 0012934
2010-12-10 10:32 amitkhullar Status new => resolved
2010-12-10 10:32 amitkhullar Resolution open => won't fix
2010-12-10 10:32 amitkhullar Assigned To => amitkhullar
2011-01-04 19:56 amitkhullar Status resolved => assigned
2011-01-04 19:56 amitkhullar Resolution won't fix => reopened
2011-01-04 19:56 amitkhullar Status assigned => resolved
2011-01-04 19:56 amitkhullar Fixed in Version => 1.9.1 (bug fixing)
2011-01-04 19:56 amitkhullar Resolution reopened => duplicate
2011-01-04 20:21 fman Note Added: 0013151
2011-01-05 04:58 amitkhullar Status resolved => assigned
2011-01-05 04:58 amitkhullar Resolution duplicate => reopened
2011-01-05 04:58 amitkhullar Relationship added related to 0003995
2011-01-05 04:58 amitkhullar Relationship added related to 0004115
2011-01-05 04:58 amitkhullar Status assigned => resolved
2011-01-05 04:58 amitkhullar Resolution reopened => fixed
2011-01-22 15:11 fman Note Added: 0013376
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker