Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004086TestLinkAPI - XMLRPCpublic2010-12-09 04:092011-01-22 15:11
Reporterasdone 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004086: Unexpected result when overwriting reportTCResult
DescriptionWhen overwriting , execution result will always write to the first assigned testcase.

Already apply fix in 0004082: Missing check of overwrite parameter in function reportTCResult (xmlrpc.class.php). The result is the same as unpatched version.
Steps To Reproduceoverwrite execution result of any testcase instead of the first assigned testcase
Additional InformationMy debug info for reference:

Report First testcase
arg: devKey 3eb1131867ce3296c87616662e861a79 testcaseid 946 testplanid 943 buildid 2 status p platformname NCP-5360 overwrite 1
Result: status 1 operation reportTCResult overwrite 1 message Success! id 715

Report Second testcase
arg: devKey 3eb1131867ce3296c87616662e861a79 testcaseid 952 testplanid 943 buildid 2 status b platformname NCP-5360 overwrite 1
Result: status 1 operation reportTCResult overwrite 1 message Success! id 715

After execution, the status of the first testcase will change to "b", which is specified for the second testcase.

Note: The result ID only changes when reporting the first testcase without overwriting. I think it's always the last execution ID for the first assigned testcase
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql 5.1.41
BrowserFirefox
PHP VersionPHP 5.3.2-1ubuntu4.5 with Suhosin-Patch (cli) (built: Sep 17 2010 13:41:55)
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-4082-4086.zip [^] (74,008 bytes) 2010-12-12 09:18

- Relationships
duplicate of 0004082closedfman Missing check of overwrite parameter in function reportTCResult (xmlrpc.class.php) 
child of 0004039closed Availables Fixes for 1.9.0 (Prague) 

-  Notes
(0012920)
fman (administrator)
2010-12-09 09:40

please detailed steps to reproduce
(0012923)
asdone (reporter)
2010-12-09 10:26
edited on: 2010-12-09 10:26

1. Add two testcases to testplan

2. Call API reportTCResult to report both of the execution results with parameter overwrite set to "FALSE"

3. Call API reportTCResult to report both of the execution results with parameter overwrite set to "TRUE"

The result of the second testcase will write to the first testcase

(0012943)
kr1shnakk (reporter)
2010-12-11 19:30
edited on: 2010-12-11 19:38

I tried with the latest CVS snapshot of 1.9 Branch and didn't have much success either. It appears to me (looking into the executions table in the database) that executions.tcversion_id is not take into consideration when doing either fetch or post operation for the second testcase and seems to get the first row, which would obviously have the id for the first testcase.

(0012944)
fman (administrator)
2010-12-12 07:55
edited on: 2010-12-12 07:56

Using CVS snapshot is always a bad idea, because can be instable, use only code provided on release + fixes.
Use CVS only on Dev Tea, request
And as usual provide detailed steps of your tests.
i.i please use a QA approach

(0012947)
fman (administrator)
2010-12-12 09:19

Apply attached fix and let us know
(0012949)
kr1shnakk (reporter)
2010-12-12 18:40
edited on: 2010-12-12 19:02

fman, I very much appreciate the quick response. The reason I tried the snapshot was I am not aware of how to get all the fixes put in place for 1.9RC. Please let me know of a better approach to follow to obtain all fixes.

This issue is almost resolved now with the patch. I tried it on both the 1.9RC and cvs 1.9 snapshot files and the correct records are as expected when using the overwrite parameter with true/1/0 values. But when using a value of "false" with overwrite param, the API always updates the last record and doesn't add a new record.

(0012950)
fman (administrator)
2010-12-12 19:22

1. thanks for helping to find issues
2. ISSUE 0004039 - Availables Fixes for 1.9.0 (Prague)
we try to use it as container of ALL AVAILABLES fixes

If you find TL useful spread the news :
a. adding your company on forum
b. thumb UP on sourceforge
c. vote on jumbox site to ask them to create a JUMPBOX for TestLink
(0013394)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-09 04:09 asdone New Issue
2010-12-09 09:40 fman Note Added: 0012920
2010-12-09 10:26 asdone Note Added: 0012923
2010-12-09 10:26 asdone Note Edited: 0012923 View Revisions
2010-12-11 19:30 kr1shnakk Note Added: 0012943
2010-12-11 19:38 kr1shnakk Note Edited: 0012943 View Revisions
2010-12-12 07:55 fman Note Added: 0012944
2010-12-12 07:56 fman Note Edited: 0012944 View Revisions
2010-12-12 08:26 fman Relationship added duplicate of 0004082
2010-12-12 09:18 fman File Added: fix-4082-4086.zip
2010-12-12 09:19 fman Note Added: 0012947
2010-12-12 09:22 fman Assigned To => fman
2010-12-12 09:22 fman Status new => assigned
2010-12-12 18:40 kr1shnakk Note Added: 0012949
2010-12-12 18:43 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 18:46 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 18:46 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 18:54 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 18:55 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 18:55 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 19:02 kr1shnakk Note Edited: 0012949 View Revisions
2010-12-12 19:20 fman Relationship added child of 0004039
2010-12-12 19:22 fman Note Added: 0012950
2010-12-12 19:22 fman Status assigned => resolved
2010-12-12 19:22 fman Fixed in Version => 1.9.1 (bug fixing)
2010-12-12 19:22 fman Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013394
2011-01-22 15:11 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker