Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004079TestLinkTest Executepublic2010-12-06 16:472011-01-22 15:11
Reporteroileanach 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows server 2003OS Versionsp 2
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004079: Cannot add attachment to execution [DB REPOSITORY / MSSQL]
DescriptionWhen you try to add an attachment to the execution section a

Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\testlink\lib\functions\common.php on line 88

Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\testlink\lib\functions\logger.class.php on line 1071
Steps To ReproduceAdd some tests to the exection section
Fail test
Choose to add attachment
Browse to file and choose upload

Results: File does not get uploaded and error from description section is shown
TagsNo tags attached.
Database (MySQL,Postgres,etc)SQL Server
BrowserIE6
PHP Version5x
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon cantOpenFileFS.png [^] (46,316 bytes) 2010-12-08 10:57

- Relationships
related to 0004085closedfman Attachment Repository on Database - Can not get file after upload 
related to 0004093closedfman MSSQL - Problems on fetch_array() 

-  Notes
(0012863)
fman (administrator)
2010-12-06 17:11

size of attachment?
(0012881)
oileanach (reporter)
2010-12-07 10:07

The attachment was a screen shot that was 125k
(0012882)
fman (administrator)
2010-12-07 10:09
edited on: 2010-12-07 10:09

config to save attachment TO DISK or DB ?
MSSQL version ?
PHP version ?
WEB SERVER ?

(0012885)
oileanach (reporter)
2010-12-07 10:23

/** the type of the repository can be database or filesystem
 * TL_REPOSITORY_TYPE_DB => database
 * TL_REPOSITORY_TYPE_FS => filesystem
 **/
$g_repositoryType = TL_REPOSITORY_TYPE_DB;

Config to save to DB.

If im not mistaken MSSQL 2008 is not supported but because of company policy i had to use it.

Im using XAMPP 1.7.3, including:
Apache 2.2.14 (IPv6 enabled) + OpenSSL 0.9.8l
PHP 5.3.1
(0012886)
oileanach (reporter)
2010-12-07 11:10

I forgot to mention, MSSQL 2008 is in 2005 compatibility mnode so is basically mssql 2005 (from what im led to believe)
(0012897)
fman (administrator)
2010-12-07 19:51

Fresh Install on windows XP
XAMPP 1.7.3 + SQL EXPRESS 2005 on save Laptop
Unable to reproduce
(0012898)
fman (administrator)
2010-12-07 19:51

Please try configuring attachment repository as File System
(0012909)
oileanach (reporter)
2010-12-08 10:56

Changed this config to point to FS.
I get the message stating that the file was uploaded successfully but when i try and click on the attachment to open it - it doesnt open. There is no hyperlink for the file like there was in previous versions. See new screen shot
(0012910)
oileanach (reporter)
2010-12-08 11:00

When i choose to delete the file i get the message stating "Really delete the attachment ' ' ?". This suggests to me that the attachment cant be found
(0012914)
fman (administrator)
2010-12-08 11:42
edited on: 2010-12-08 11:43

Please when attaching file give it a description, to get link to get file,
seems something is wrong and NO ICON is displayed when no description is given.

please apply fix available on related issue.
and test with both kind of repository

(0012918)
oileanach (reporter)
2010-12-09 09:23

This works for file system. When you give a description to the file, the description is the hyperlink and the file can be opened.

However when you switch to DB - if you browse to the attachment, give it a description, then choose to upload file then the original bug is still reproduceable
(0012919)
fman (administrator)
2010-12-09 09:39

is not clear for me: have you applied fix present on issue 4085
(0012929)
oileanach (reporter)
2010-12-10 08:56

Yes, i copied in the php file attached to issue 4085 and replaced the version in the testlink lib and the same issue is still present as described in original bug
(0013197)
fman (administrator)
2011-01-06 18:41

Please get updated fix (now is tar.gz) on related issue, Apply it, retest and let us know.
Problem was database.class.php not present on first fix, but present on my system.
(0013320)
fman (administrator)
2011-01-18 21:27

no more user feedback
(0013349)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-12-06 16:47 oileanach New Issue
2010-12-06 17:11 fman Note Added: 0012863
2010-12-07 10:07 oileanach Note Added: 0012881
2010-12-07 10:09 fman Note Added: 0012882
2010-12-07 10:09 fman Note Edited: 0012882 View Revisions
2010-12-07 10:09 fman Note Edited: 0012882 View Revisions
2010-12-07 10:23 oileanach Note Added: 0012885
2010-12-07 11:10 oileanach Note Added: 0012886
2010-12-07 19:51 fman Note Added: 0012897
2010-12-07 19:51 fman Note Added: 0012898
2010-12-07 20:18 fman Assigned To => fman
2010-12-07 20:18 fman Status new => assigned
2010-12-08 10:56 oileanach Note Added: 0012909
2010-12-08 10:57 oileanach File Added: cantOpenFileFS.png
2010-12-08 11:00 oileanach Note Added: 0012910
2010-12-08 11:42 fman Note Added: 0012914
2010-12-08 11:42 fman Relationship added related to 0004085
2010-12-08 11:43 fman Note Edited: 0012914 View Revisions
2010-12-08 11:43 fman Status assigned => feedback
2010-12-09 09:23 oileanach Note Added: 0012918
2010-12-09 09:23 oileanach Status feedback => assigned
2010-12-09 09:39 fman Note Added: 0012919
2010-12-09 17:29 fman Status assigned => feedback
2010-12-10 08:56 oileanach Note Added: 0012929
2010-12-10 08:56 oileanach Status feedback => assigned
2011-01-03 21:16 fman Summary Cannot add attachment to execution => Cannot add attachment to execution [DB REPOSITORY / MSSQL]
2011-01-06 18:41 fman Note Added: 0013197
2011-01-06 18:41 fman Relationship added related to 0004093
2011-01-06 18:44 fman Status assigned => feedback
2011-01-18 21:27 fman Note Added: 0013320
2011-01-18 21:27 fman Status feedback => resolved
2011-01-18 21:27 fman Fixed in Version => 1.9.1 (bug fixing)
2011-01-18 21:27 fman Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013349
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker