Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004067TestLinkTest Specificationpublic2010-11-30 21:082011-01-22 15:12
Reporterbizob28 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLAMPOSfedoraOS Version13
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004067: Tree refreshes after every action taken in Test Specification when update tree is disabled
DescriptionI've been spinning my wheels today. I upgraded to 1.9 and cannot figure out why the auto tree refresh is happening.

there is a configuration option:
$tlCfg->spec_cfg->automatic_tree_refresh, i have that equal to DISABLED. However every time i create a new test case, edit and existing, deleted, the tree is refreshed. I've also tried it via the checkbox in the tree "Update tree after every operation" but that is not taken into consideration on any action. Also, disabled this $tlCfg->tree_filter_cfg->requirements->automatic_tree_refresh, but I don't know where this is being used
Steps To Reproduce 1. Disable the automatic tree refresh
 2. access specification
 3. Create test case

expected result
test case is created but tree is not refreshed
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 3.6.12
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-4067.zip [^] (59,622 bytes) 2010-12-03 07:38

- Relationships
has duplicate 0004084closedasimon Update tree after every operation ignored in Test Case editor 
child of 0004039closed Availables Fixes for 1.9.0 (Prague) 

-  Notes
(0012775)
Julian (reporter)
2010-11-30 21:53

would you please check "Update tree after every operation" checkbox on settings panel (on the top of test case / requirement tree)
(0012784)
bizob28 (reporter)
2010-12-01 14:27

Same behavior with our without "update tree after every operation" checked. The site tree always refreshes. I enabled smart_debug and i have confirmed it is reading the configuration: $tlCfg->spec_cfg->automatic_tree_refresh=DISABLED;
(0012801)
asimon (developer)
2010-12-02 08:42

Yes, I can confirm it too.

Happens only for test cases, not requirements.
(0012804)
asimon (developer)
2010-12-02 10:24

Found & fixed.
(0012810)
bizob28 (reporter)
2010-12-02 15:18

This is still a problem in some cases. The steps to reproduce were only detailing create test case, however edit test case is experiencing the same issue.
(0012811)
bizob28 (reporter)
2010-12-02 16:12

Also an issue on delete test case. So to make sure this is completely addressed it will be any action that will cause an update to a test case.
(0012814)
asimon (developer)
2010-12-02 17:59

Bug has been fixed. Not only for the case mentioned in steps to reproduce, but in all cases.
(0012816)
bizob28 (reporter)
2010-12-02 18:11

Ok, so what's the easiest way to get a changeset from your source control? I was only able to find tcNew.tpl changed
(0012817)
bizob28 (reporter)
2010-12-02 18:52

I did a global search in your source code for BUGID 4067 and only find tcNew.tpl
(0012829)
asimon (developer)
2010-12-03 07:38

That's because I did not backport all fixes I performed on head to 1.9 branch.

I attached a fix.
(0012834)
bizob28 (reporter)
2010-12-03 15:06

so how can users who logged bugs confirm that there bugs are fixed before release or get the fix? Problem i have is, you will fix something and close the ticket and i then have to reopen it to add notes, are we able to email you directly for fixes?
(0012836)
asimon (developer)
2010-12-03 17:25

That is the reason why we normally attach zipped fixed to the issues we resolve on Mantis.
(0013400)
fman (administrator)
2011-01-22 15:12

1.9.1. released

- Issue History
Date Modified Username Field Change
2010-11-30 21:08 bizob28 New Issue
2010-11-30 21:54 Julian Note Added: 0012775
2010-12-01 14:27 bizob28 Note Added: 0012784
2010-12-02 08:42 asimon Note Added: 0012801
2010-12-02 10:24 asimon Note Added: 0012804
2010-12-02 10:24 asimon Status new => resolved
2010-12-02 10:24 asimon Fixed in Version => 1.9.1 (bug fixing)
2010-12-02 10:24 asimon Resolution open => fixed
2010-12-02 10:24 asimon Assigned To => asimon
2010-12-02 15:18 bizob28 Note Added: 0012810
2010-12-02 15:18 bizob28 Status resolved => assigned
2010-12-02 15:18 bizob28 Resolution fixed => reopened
2010-12-02 16:12 bizob28 Note Added: 0012811
2010-12-02 17:59 asimon Note Added: 0012814
2010-12-02 17:59 asimon Status assigned => resolved
2010-12-02 17:59 asimon Resolution reopened => fixed
2010-12-02 18:11 bizob28 Note Added: 0012816
2010-12-02 18:11 bizob28 Status resolved => assigned
2010-12-02 18:11 bizob28 Resolution fixed => reopened
2010-12-02 18:52 bizob28 Note Added: 0012817
2010-12-03 07:38 asimon Note Added: 0012829
2010-12-03 07:38 asimon File Added: fix-4067.zip
2010-12-03 15:06 bizob28 Note Added: 0012834
2010-12-03 17:25 asimon Note Added: 0012836
2010-12-03 17:26 asimon Status assigned => resolved
2010-12-03 17:26 asimon Resolution reopened => fixed
2010-12-08 09:37 asimon Relationship added has duplicate 0004084
2010-12-08 10:01 fman Relationship added child of 0004039
2011-01-22 15:12 fman Note Added: 0013400
2011-01-22 15:12 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker