Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004065TestLinkUsers and Rightspublic2010-11-30 14:122011-01-22 15:12
Reportermr0vek@o2.pl 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004065: errors from SQL
DescriptionErrors from SQL are visible in "User Management" -> "Assign roles" -> last tab: "Assign TestPlan roles" when there's no testPlan created yet.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-4065.zip [^] (41,419 bytes) 2010-12-02 06:43

- Relationships
duplicate of 0004028closedfman Assign rule test plan test plan without registered 
child of 0004039closed Availables Fixes for 1.9.0 (Prague) 

-  Notes
(0012772)
fman (administrator)
2010-11-30 21:12
edited on: 2010-11-30 21:12

1. subject is meaningless
2. give detailed steps to reproduce

(0012786)
mr0vek@o2.pl (reporter)
2010-12-01 15:29

Steps to reproduce:

1. Install clean instance of TestLink
2. Create new project, test case and user
3. Go to "User Management" -> "Assign roles" -> click last tab: "Assign TestPlan roles".

Notice error and dumped SQL queries. First one ends with: ", -1"
(0012788)
fman (administrator)
2010-12-01 15:58

If there are NO test plan defines, surely this will fail.
Surelly we need to make it fail gently
(0012799)
fman (administrator)
2010-12-02 06:43

use attached fix, retest and let us know
(0012806)
mr0vek@o2.pl (reporter)
2010-12-02 10:45

Yes, it's fixed. When there's no plan (and when all plans are disabled) then a nice message: "There are no usable test plans on this test project" is shown instead of errors.

Thank you very much.
(0013408)
fman (administrator)
2011-01-22 15:12

1.9.1. released

- Issue History
Date Modified Username Field Change
2010-11-30 14:12 mr0vek@o2.pl New Issue
2010-11-30 21:12 fman Note Added: 0012772
2010-11-30 21:12 fman Note Edited: 0012772 View Revisions
2010-12-01 15:29 mr0vek@o2.pl Note Added: 0012786
2010-12-01 15:58 fman Note Added: 0012788
2010-12-02 06:39 fman Assigned To => fman
2010-12-02 06:39 fman Status new => assigned
2010-12-02 06:43 fman File Added: fix-4065.zip
2010-12-02 06:43 fman Note Added: 0012799
2010-12-02 06:43 fman Status assigned => feedback
2010-12-02 10:45 mr0vek@o2.pl Note Added: 0012806
2010-12-02 10:45 mr0vek@o2.pl Status feedback => assigned
2010-12-02 10:58 fman Status assigned => resolved
2010-12-02 10:58 fman Fixed in Version => 1.9.1 (bug fixing)
2010-12-02 10:58 fman Resolution open => fixed
2010-12-02 18:28 fman Relationship added child of 0004039
2010-12-08 09:59 fman Relationship added duplicate of 0004028
2011-01-22 15:12 fman Note Added: 0013408
2011-01-22 15:12 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker