Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004062TestLinkUsers and Rightspublic2010-11-29 16:312011-07-02 13:48
Reporterroberto.braga@sociale.it 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004062: General user rights overide user rigths at test plan level (after migration from 1.8.5 to 1.9.x)
DescriptionUser rights at user level overide the rights setted at test plan level.
I just setted no rights for some users in order to activate specific access level only on some test plan.
Even givin the admin role on these test plans they still have no menu.

User rights at test project level works as expected.
Steps To ReproduceAssign to a user a role
Assign a different role in a specific test plan
verify if the options in the specific test plan match the setting
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon testlink_1-8-5.sql.zip [^] (6,086 bytes) 2011-03-25 16:25
zip file icon testlink.sql.zip [^] (6,833 bytes) 2011-03-25 16:25

- Relationships
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0012748)
fman (administrator)
2010-11-29 19:28

1. please give detailed steps to reproduce (i.e. what you have done).
2. using admin role on Test Plan is not a good idea.
(0012765)
roberto.braga@sociale.it (reporter)
2010-11-30 10:02

More detailed steps:
Beeing more practical:
1) I have a user John Doe to which I assign the role <no rights>
2) Then I assign "senior tester" role to John Doe in a specific test paln "regression tests"
3) Entering with the user John Doe I expect to have access as "senior tester" only to "regression tests" test plan. But Instead I have <no rights> to all test plans included "regression tests"

I think that testlink "see" in some way that the user has a different access level to the "regression tests" test plan since is the only one that appear in the dropdown menu.

As side note the previous version 1.8.5 of test link was working as expected, my 1.9.0 installation is an upgrade.
I was using this kind of configuration in the 1.8.5, it stopped to work after the upgrade.
(0012767)
alenart (reporter)
2010-11-30 12:07

Same for our installation (upgrade from 1.8.5): the default role in user information overide the rights set inside a test project
(0012769)
fman (administrator)
2010-11-30 13:10

Please provide you db zipped francisco.mancardi@gmail.com
(0014196)
JensFF (reporter)
2011-03-21 11:36

I see the same problem after upgrading from 1.8.5 to 1.9.1. It worked with 1.8.5 and is broken now.
I can't provide the db as it contains confidential information. But I can look into the db if it helps.
(0014199)
fman (administrator)
2011-03-21 19:14

unfortunatelly without db is near impossible to debug this issue.
you can scramble all confidential data and send the db.
(0014284)
JensFF (reporter)
2011-03-25 16:28

I've created a nearly empty database with 1.8.5. and moved it to 1.9.1.
User tester (pwd: tester) has project right tester. For myPlan I assigned leader rights to him.
In the 1.8.5 db "tester" can add test cases to test plan "myPlan". In the 1.9.1 db he can't.
(0014286)
fman (administrator)
2011-03-25 22:11

here code that fix this issue:
http://gitorious.org/testlink-ga/testlink-code/commit/39e29b41e639cb5921a7e2c884ce4918ed5c5106 [^]

please get it, test and give us feedback
(0014352)
JensFF (reporter)
2011-03-29 16:17

Tested the fix with the uploaded DB. Fix is working!
Thank you
(0015409)
fman (administrator)
2011-07-02 13:48

1.9.3 released

- Issue History
Date Modified Username Field Change
2010-11-29 16:31 roberto.braga@sociale.it New Issue
2010-11-29 19:28 fman Note Added: 0012748
2010-11-30 10:02 roberto.braga@sociale.it Note Added: 0012765
2010-11-30 12:07 alenart Note Added: 0012767
2010-11-30 13:10 fman Note Added: 0012769
2011-03-21 11:36 JensFF Note Added: 0014196
2011-03-21 19:14 fman Note Added: 0014199
2011-03-21 19:31 fman Summary General user rights overide user rigths at test plan level => General user rights overide user rigths at test plan level (after migration from 1.8.5 to 1.9.x)
2011-03-25 16:25 JensFF File Added: testlink_1-8-5.sql.zip
2011-03-25 16:25 JensFF File Added: testlink.sql.zip
2011-03-25 16:28 JensFF Note Added: 0014284
2011-03-25 22:11 fman Note Added: 0014286
2011-03-25 22:16 fman Assigned To => fman
2011-03-25 22:16 fman Status new => feedback
2011-03-29 16:17 JensFF Note Added: 0014352
2011-03-29 16:34 fman Status feedback => resolved
2011-03-29 16:34 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-03-29 16:34 fman Resolution open => fixed
2011-03-29 16:35 fman Relationship added child of 0004337
2011-07-02 13:48 fman Note Added: 0015409
2011-07-02 13:48 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker