Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004049TestLinkRequirement Managementpublic2010-11-23 14:312011-07-02 13:49
ReporterJulian 
Assigned Toasimon 
PriorityhighSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004049: Ajax login on timeout for requirements to avoid data loss
DescriptionReuse mechanism used on Test Case edit to avoid data loss when session expires.
Steps To Reproduce1. Go to edit test case - write some text (don't save)
2. open testlink in a new tab and press logout - this simulates logout after timeout
3. Go back to the edited test case and press save
4. A popup window appears above the test case
5. Enter credentials and login
6. Your login and the test case is saved.
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0004051closedJulian Ajax login on timeout for requirement specifications to avoid data loss 
related to 0004536closedfman Tree is not refreshed after editing Requirement 

-  Notes
(0012716)
Julian (reporter)
2010-11-23 14:35

Reminder sent to: Eloff

Erik, how much effort is required?
(0012717)
Julian (reporter)
2010-11-23 16:14

found out how this works. after this change tree is not refreshed anymore after editing. we are looking for a solution.
(0012718)
Eloff (reporter)
2010-11-23 18:36

It should not require much effort, basically just the js that is needed on the page. But I haven't looked on the code now and will not have time to implement it
(0012721)
Julian (reporter)
2010-11-24 08:17

andreas and me will take care of it.

i will assign to you andreas because we need a solution for the tree refresh problem after editing requirement.
-> tree may first be refreshed after form validation passed
(0012723)
Julian (reporter)
2010-11-24 17:12

ajax login on timeout checked in for branch 1.9 and head.

needs to be fixed: tree is not refreshed anymore when submitting form (not as critical as data loss)
(0015050)
Julian (reporter)
2011-06-01 20:46

major issue has been fixed. tree refresh issue will be tracked in 0004536
(0015441)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2010-11-23 14:31 Julian New Issue
2010-11-23 14:35 Julian Note Added: 0012716
2010-11-23 16:14 Julian Note Added: 0012717
2010-11-23 18:36 Eloff Note Added: 0012718
2010-11-24 08:17 Julian Assigned To => asimon
2010-11-24 08:17 Julian Status new => assigned
2010-11-24 08:17 Julian Note Added: 0012721
2010-11-24 16:19 Julian Issue cloned: 0004051
2010-11-24 16:19 Julian Relationship added related to 0004051
2010-11-24 17:12 Julian Note Added: 0012723
2011-06-01 20:41 Julian Relationship added related to 0004536
2011-06-01 20:46 Julian Note Added: 0015050
2011-06-01 20:46 Julian Status assigned => resolved
2011-06-01 20:46 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-06-01 20:46 Julian Resolution open => fixed
2011-07-02 13:49 fman Note Added: 0015441
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker