Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004042TestLinkUser Interface Generalpublic2010-11-21 08:122011-01-22 15:12
ReporterJulian 
Assigned Toasimon 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0004042: "Expand/Collapse" Button for Trees
DescriptionIt would be great to have a button to Expand/Collapse the whole tree with one click.
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0012683)
fman (administrator)
2010-11-21 10:25

Just tried on Test Spec

Changes needed:
ON each .js where we have created the tree, example (treebyloader.js)
we need to make tree object GLOBAL instead of local doing just:

// added config option copyOrMove, can be used (RW) with this access path
// .initialConfig.copyOrMove
//
var tree = new Tree.TreePanel({ FROM
        el:treeCfg.tree_div_id,

TO
tree = new Tree.TreePanel({
        el:treeCfg.tree_div_id,


After this need to add (simplest solution) two buttons on inc_filter_panel.tpl

<input type="button" value="Expand Tree" (need to be localized)
id="expand_tree"
                   name="expand_tree"
                   onclick="tree.expandAll();"
                   style="font-size: 90%;" />

<input type="button" value="Collapse Tree" (need to be localized)
id="collapse_tree"
                   name="collapse_tree"
                   onclick="tree.collapseAll();"
                   style="font-size: 90%;" />

and all works
(0012687)
Julian (reporter)
2010-11-21 12:34
edited on: 2010-11-21 12:39

maybe filter panel is not the best place for this - but ok...
alternative would be another "single line div" above tree.

if you think the solution can be added - great ;)

(0012689)
fman (administrator)
2010-11-21 16:24

>> maybe filter panel is not the best place for this - but ok.
is the simplest alternative (look at this as a Quick & Dirty [not too much dirty IMHO] solution)

I will assign to you this issue.
IMHO can be also commited to 1.9 Branch
(0012690)
Julian (reporter)
2010-11-21 16:28

i will pass it on to andreas, because he is the master of filter panel and has to make a decision here.
(0012692)
asimon (developer)
2010-11-21 16:54

Done!
(0013411)
fman (administrator)
2011-01-22 15:12

1.9.1. released

- Issue History
Date Modified Username Field Change
2010-11-21 08:12 Julian New Issue
2010-11-21 10:25 fman Note Added: 0012683
2010-11-21 12:34 Julian Note Added: 0012687
2010-11-21 12:39 Julian Note Edited: 0012687 View Revisions
2010-11-21 16:24 fman Note Added: 0012689
2010-11-21 16:24 fman Assigned To => Julian
2010-11-21 16:24 fman Status new => assigned
2010-11-21 16:28 Julian Assigned To Julian => asimon
2010-11-21 16:28 Julian Note Added: 0012690
2010-11-21 16:54 asimon Note Added: 0012692
2010-11-22 14:11 asimon Status assigned => resolved
2010-11-22 14:11 asimon Fixed in Version => 1.9.1 (bug fixing)
2010-11-22 14:11 asimon Resolution open => fixed
2011-01-22 15:12 fman Note Added: 0013411
2011-01-22 15:12 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker