Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004021TestLinkAPI - XMLRPCpublic2010-11-16 15:242011-03-18 19:07
Reportertom1 
Assigned Tofman 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version1.9 (Prague) 
Fixed in Version1.9.2 (2011 Q2 - bug fixing) 
Summary0004021: Remote execution of testcases doesn't work
DescriptionInvestigations to perform external/remote execution of testcases via the "Execute and save results" button shows the follwing inconsistencies:

- common.php
  Function executeTestCase is commented out (required $phpxmlrpc as well)

- cfield_mgr.class.php
  Wrong syntax in function getXMLServerParams
  Statement $ret['xml_server_host'] = $server_info[$srv_cfg->host];
  should be $ret['xml_server_host'] = $server_info[$srv_cfg->host]['value'];
  (also for port and path)
  Otherwise the values for host, port and path are not set wright.

- execSetResults.php
  Some transfer parameters in function do_remote_execution missing.
  $build_id, $user_id and $tplan_id needed to write the testresults into the database are not known in this function. Should be transferd by the caller.
TagsRemote Execution
Database (MySQL,Postgres,etc)mysql 5.1.41
BrowserFirefox
PHP Version5.3.2
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0003338closedfman Contribution: make execute_remote work 

-  Notes
(0012781)
tom1 (reporter)
2010-12-01 10:37

Additionally I investigated that platforms are not handled by external execution functions.
i.e. actual platform_id will be not written into database, instead value 0 is used. Hence the results are no more visible.
(0012795)
fman (administrator)
2010-12-01 21:37

We know we have to work on this area (some contribution to fix this are present on mantis if I'm not wrong), but we have not enough time now
(0013914)
fman (administrator)
2011-03-18 19:07

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2010-11-16 15:24 tom1 New Issue
2010-12-01 10:37 tom1 Note Added: 0012781
2010-12-01 21:37 fman Note Added: 0012795
2011-01-23 17:25 fman Tag Attached: Remote Execution
2011-01-23 18:10 fman Relationship added duplicate of 0003338
2011-03-14 21:47 fman Status new => resolved
2011-03-14 21:47 fman Fixed in Version => 1.9.2 (2011 Q2 - bug fixing)
2011-03-14 21:47 fman Resolution open => fixed
2011-03-14 21:47 fman Assigned To => fman
2011-03-18 19:07 fman Note Added: 0013914
2011-03-18 19:07 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker