Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004008TestLinkKeywordspublic2010-11-11 14:592015-04-29 14:08
Reporterschlundus 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version2.0 (planned) 
Summary0004008: User with a role with "keyword view" right (not kw manage right), can see buttons which mislead the user
Descriptionthe keywords rights are not fully be considered

See attached screenshot. Tester has only "Keyword view (read only access)" right
After login he sees part one, after clicking "Keyword management" he sees the second part (Assign-Button?) after clicking the "assign'-Button he sees part three !! After clicking a testsuite he became redirected because of missing rights (That's good)

so the gui should not present buttons which mislead the user
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon s3.JPG [^] (81,644 bytes) 2010-11-11 14:59

- Relationships
related to 0004557closedfman New right Keyword Assignment 

-  Notes
(0015121)
fman (administrator)
2011-06-03 16:26

solved using new right (see related issue)
(0023207)
Mr.Bricodage (updater)
2015-04-26 16:44

ok in TL 1.9.13

- Issue History
Date Modified Username Field Change
2010-11-11 14:59 schlundus New Issue
2010-11-11 14:59 schlundus File Added: s3.JPG
2010-11-11 15:02 schlundus Product Version => 1.9 RC 1
2011-06-03 16:26 fman Relationship added related to 0004557
2011-06-03 16:26 fman Note Added: 0015121
2011-06-03 16:27 fman Status new => resolved
2011-06-03 16:27 fman Fixed in Version => 2.0 (planned)
2011-06-03 16:27 fman Resolution open => fixed
2011-06-03 16:27 fman Assigned To => fman
2015-04-26 15:34 Mr.Bricodage Relationship added child of 0007083
2015-04-26 16:44 Mr.Bricodage Note Added: 0023207
2015-04-29 14:08 fman Status resolved => closed
2015-04-29 18:25 Mr.Bricodage Relationship deleted child of 0007083



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker