Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004006TestLinkTest Plan (builds, milestones, test assign)public2010-11-11 14:182011-01-22 15:11
Reporterschlundus 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version1.9.1 (bug fixing) 
Summary0004006: Is_public flag on testplans not used as expected?
DescriptionHow can i prevent test case execution during creating the testplan?

Situation.
1 Project, all testers have global tester role.

The leader creates a testplan, adds the testcase and assigns half the testcase to the testers.... and went home

How can i avoid that some testers already begin to test? I'd expect the Is_public Flag on Testplans for this, but i cannot find a meaningful usage of the flag in the relevant code?

So is there a solution (not the workaround with closed and inaktive builds) which makes it possible to fully prevent testers from seeing and using the plan, while creating, assign tc's to user?
And only after i finish the tp to 100% i make it ready to use?
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon fix-4006.zip [^] (16,207 bytes) 2010-11-12 20:25

- Relationships

-  Notes
(0012398)
Julian (reporter)
2010-11-11 14:29

will setting the build to "closed" help?
(0012402)
schlundus (reporter)
2010-11-11 15:02
edited on: 2010-11-11 15:34

Not really, this seems only a workaround because this leads to other strange GUI stuff (see 0004007 and 0004009). So i think the "is_public" concept is not fully implemented..

(0012408)
fman (administrator)
2010-11-11 16:09

Public on Test Plan is not implemented yet.
Check box will be removed from UI till implementation will be done.
As seems is needed will be added on first hot fix 1.9.1
(0012415)
fman (administrator)
2010-11-11 19:42

Please try with attached fix and let us know
(0012418)
schlundus (reporter)
2010-11-12 06:39

Thanks, i will try it today
(0012430)
fman (administrator)
2010-11-12 19:43

Please get fix again, because we have found an error
(0012668)
fman (administrator)
2010-11-20 10:55

any news ?
(0013200)
fman (administrator)
2011-01-06 18:47

no more user feedback
(0013370)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-11-11 14:18 schlundus New Issue
2010-11-11 14:29 Julian Note Added: 0012398
2010-11-11 15:02 schlundus Note Added: 0012402
2010-11-11 15:02 schlundus Product Version => 1.9 RC 1
2010-11-11 15:34 schlundus Note Edited: 0012402 View Revisions
2010-11-11 16:09 fman Note Added: 0012408
2010-11-11 16:18 fman Assigned To => fman
2010-11-11 16:18 fman Status new => assigned
2010-11-11 19:29 fman Status assigned => work in progress
2010-11-11 19:41 fman File Added: fix-4006.zip
2010-11-11 19:42 fman Note Added: 0012415
2010-11-11 19:42 fman Status work in progress => feedback
2010-11-12 06:39 schlundus Note Added: 0012418
2010-11-12 06:39 schlundus Status feedback => assigned
2010-11-12 19:43 fman File Deleted: fix-4006.zip
2010-11-12 19:43 fman File Added: fix-4006.zip
2010-11-12 19:43 fman Note Added: 0012430
2010-11-12 19:53 fman File Deleted: fix-4006.zip
2010-11-12 20:25 fman File Added: fix-4006.zip
2010-11-20 10:55 fman Note Added: 0012668
2010-11-20 10:55 fman Status assigned => feedback
2011-01-06 18:47 fman Note Added: 0013200
2011-01-06 18:47 fman Status feedback => resolved
2011-01-06 18:47 fman Fixed in Version => 1.9.1 (bug fixing)
2011-01-06 18:47 fman Resolution open => fixed
2011-01-22 15:11 fman Note Added: 0013370
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker