Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003998TestLinkNew Featurepublic2010-11-10 16:132011-03-18 19:07
ReporterVincent 
Assigned Toamitkhullar 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version2.0 (planned) 
Summary0003998: Add the integration for the new version of fckeditor (ckeditor)
DescriptionIt would be useful if the new version of fckeditor (ckeditor http://ckeditor.com/ [^]) would be integrated natively in testlink. So that we can chose in the config file this new editor instead of the actual chosen list ('fckeditor','tinymce','none')
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon ckeditor_integration.zip [^] (20,903 bytes) 2010-11-17 16:14

- Relationships
parent of 0004046assigned Settings for CKEditor 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0012384)
fman (administrator)
2010-11-10 16:42

Integration is too complex -> absolutely low priority
Anyway we can review your contribution if you do it
(0012625)
Vincent (reporter)
2010-11-17 16:26

I haved done the integration of ckeditor into testlink

I have added the file to use ckeditor in testlink (files are based on the 1.9 prague release)

To use it you also have to download ckeditor and ckfinder (if you want to upload image) and put it into the third_party folder

It works well.
(0012626)
fman (administrator)
2010-11-17 16:42

all what we need is inside attached file ?
do you have some instructions ?
(0012636)
Vincent (reporter)
2010-11-17 21:11

All the modified or added files are in the attached file (I hope I have not omit files). But only testlink files, I haven't put ckeditor and ckfinder just download and put folders into third_party folder

modified files :
config.inc.php : editor's choice put to 'ckeditor' and link to configFile updated

lib/functions/web_editor.php : switch handle the case 'ckeditor'

added files :
lib/functions/ckeditor.class.php : to make a bridge beetwen testlink and ckeditor because function's name of ckeditor are not the some as fckeditor.

cfg/tl_ckeditor_config.js : you can put our customisation into this file but config options are not the same than fckeditor so tl_fckeditor.js cannot be use whit ckeditor. I have set back the fckeditor testlink toolbar into this configurations file
the available options : http://docs.cksource.com/ckeditor_api/symbols/CKEDITOR.config.html [^]
(0012637)
fman (administrator)
2010-11-17 21:35

OK, thanks we will try to use this and add on 2.0
(0012638)
fman (administrator)
2010-11-17 21:36

Reminder sent to: amitkhullar, asimon, Eloff, Julian

Volunteer to add and test this to HEAD (2.0) needed
(0012639)
amitkhullar (reporter)
2010-11-18 07:12

sure will try this out.
(0012700)
amitkhullar (reporter)
2010-11-22 11:57

Checked in cvs head
(0012705)
Julian (reporter)
2010-11-22 16:42

thanks amit,

could you please fix that:

117 if (isset($webEditorCfg['height']))
118 $of->Editor->Height = $webEditorCfg['height'];
119 if (isset($webEditorCfg['width']))
120 $of->Editor->Width = $webEditorCfg['width'];

it should be :

117 if (isset($webEditorCfg['height']))
118 $of->Editor->config['height'] = $webEditorCfg['height'];
119 if (isset($webEditorCfg['width']))
120 $of->Editor->config['width'] = $webEditorCfg['width'];
(0012707)
Julian (reporter)
2010-11-22 21:14

done. also updated config file
(0013928)
fman (administrator)
2011-03-18 19:07

release - 1.9.2 - 20110320

- Issue History
Date Modified Username Field Change
2010-11-10 16:13 Vincent New Issue
2010-11-10 16:42 fman Note Added: 0012384
2010-11-10 17:21 fman Summary Ad the integration for the new version of fckeditor (ckeditor) => Add the integration for the new version of fckeditor (ckeditor)
2010-11-17 16:14 Vincent File Added: ckeditor_integration.zip
2010-11-17 16:26 Vincent Note Added: 0012625
2010-11-17 16:42 fman Note Added: 0012626
2010-11-17 21:11 Vincent Note Added: 0012636
2010-11-17 21:35 fman Note Added: 0012637
2010-11-17 21:36 fman Note Added: 0012638
2010-11-18 07:12 amitkhullar Note Added: 0012639
2010-11-22 11:57 amitkhullar Note Added: 0012700
2010-11-22 11:57 amitkhullar Status new => resolved
2010-11-22 11:57 amitkhullar Fixed in Version => 2.0 (planned)
2010-11-22 11:57 amitkhullar Resolution open => fixed
2010-11-22 11:57 amitkhullar Assigned To => amitkhullar
2010-11-22 14:17 Julian Issue cloned: 0004046
2010-11-22 14:17 Julian Relationship added parent of 0004046
2010-11-22 16:42 Julian Note Added: 0012705
2010-11-22 16:42 Julian Status resolved => assigned
2010-11-22 16:42 Julian Resolution fixed => reopened
2010-11-22 21:14 Julian Note Added: 0012707
2010-11-22 21:14 Julian Status assigned => resolved
2010-11-22 21:14 Julian Resolution reopened => fixed
2011-03-18 19:07 fman Note Added: 0013928
2011-03-18 19:07 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker