Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003995TestLinkCustom fieldspublic2010-11-10 06:572011-01-22 15:11
Reporteramitkhullar 
Assigned Toamitkhullar 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 (Prague) 
Fixed in Version1.9.1 (bug fixing) 
Summary0003995: Custom Field Filters in Test case Execution : Dont Work
DescriptionThere was a change in the data type being used inthe sql
earlier it was string but later on changed to array

TagsNo tags attached.
Database (MySQL,Postgres,etc)1.9
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesrar file icon 4024.rar [^] (10,995 bytes) 2010-12-10 11:52
rar file icon 3995.rar [^] (86,059 bytes) 2010-12-10 11:52

- Relationships
related to 0004024closedamitkhullar Add Test Case to Test Plan gives sql error on filtering the test cases on custom field value 
related to 0003889closedfman Add Test Cases to Test plan - Right pane shows all test cases of a test suite and does not consider test cases of filtered tree 
related to 0004115closedamitkhullar Custom Field Filters in Test case specs dont work in a corner condition 
related to 0004087closedamitkhullar Filtering Test Cases by more than one custom field gives zero results 
child of 0004039closed Availables Fixes for 1.9.0 (Prague) 

-  Notes
(0012354)
amitkhullar (reporter)
2010-11-10 07:05

Fixed in Head, couldnt find the 1.9.1 trunk in cvs
(0012355)
fman (administrator)
2010-11-10 09:00
edited on: 2010-11-10 09:00

amit:

THERE IS NO SUCH THING as 1.9.1 BRANCH.
Because is an issue Commit to testlink_1_9 branch

Explain clearly what was the problems your previous explanation is confusing.
and the detailed steps to reproduce

(0012646)
amitkhullar (reporter)
2010-11-18 11:15
edited on: 2010-11-18 11:16

reopening issue, code was breaking in some scenarios, need to fixed properly this time

(0012647)
amitkhullar (reporter)
2010-11-18 11:42

Checked in 1.9 trunk and 2.0
(0012938)
amitkhullar (reporter)
2010-12-10 11:54

Please use the fixes for both 3995 and 4024 to fix the problem for custom filters across the application. Attaching on both the issues.
(0013395)
fman (administrator)
2011-01-22 15:11

1.9.1 Released

- Issue History
Date Modified Username Field Change
2010-11-10 06:57 amitkhullar New Issue
2010-11-10 06:57 amitkhullar Status new => assigned
2010-11-10 06:57 amitkhullar Assigned To => amitkhullar
2010-11-10 07:05 amitkhullar Note Added: 0012354
2010-11-10 07:05 amitkhullar Status assigned => resolved
2010-11-10 07:05 amitkhullar Fixed in Version => 2.0.0 (planned)
2010-11-10 07:05 amitkhullar Resolution open => fixed
2010-11-10 09:00 fman Note Added: 0012355
2010-11-10 09:00 fman View Status public => private
2010-11-10 09:00 fman Note Edited: 0012355 View Revisions
2010-11-17 10:14 amitkhullar Relationship added related to 0004024
2010-11-18 11:15 amitkhullar Note Added: 0012646
2010-11-18 11:15 amitkhullar Status resolved => assigned
2010-11-18 11:15 amitkhullar Resolution fixed => reopened
2010-11-18 11:16 amitkhullar Note Edited: 0012646 View Revisions
2010-11-18 11:42 amitkhullar Note Added: 0012647
2010-11-18 11:42 amitkhullar Status assigned => resolved
2010-11-18 11:42 amitkhullar Fixed in Version 2.0.0 (planned) => 1.9.1 (bug fixing)
2010-11-18 11:42 amitkhullar Resolution reopened => fixed
2010-12-08 11:37 fman View Status private => public
2010-12-10 11:52 amitkhullar Status resolved => assigned
2010-12-10 11:52 amitkhullar Resolution fixed => reopened
2010-12-10 11:52 amitkhullar File Added: 4024.rar
2010-12-10 11:52 amitkhullar File Added: 3995.rar
2010-12-10 11:54 amitkhullar Note Added: 0012938
2010-12-10 11:54 amitkhullar Status assigned => resolved
2010-12-10 11:54 amitkhullar Resolution reopened => fixed
2010-12-10 11:56 amitkhullar Relationship added related to 0003889
2010-12-21 11:32 amitkhullar Relationship added related to 0004115
2010-12-21 11:34 amitkhullar Relationship added child of 0004039
2011-01-05 04:58 amitkhullar Relationship added related to 0004087
2011-01-22 15:11 fman Note Added: 0013395
2011-01-22 15:11 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker