Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003951TestLinkRequirement Managementpublic2010-10-28 05:122010-11-14 12:07
ReporterKathrinMarkus 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version1.9 (Prague) 
Summary0003951: Status and Type for requirements are not saved
Descriptionif I edit a requirement I can change the status and the type for a requirement. But this change will be never saved in the database (field is always empty).
Steps To Reproduceedit an existing requirement
change the status and the type
save
check status and type => isn't set (NOK)
TagsNo tags attached.
Database (MySQL,Postgres,etc)-
BrowserFirefox 3.6.10, Internet Explorer 8
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0012109)
Julian (reporter)
2010-10-28 07:25

works with mysql -> mssql added to summary
(0012112)
KathrinMarkus (reporter)
2010-10-28 09:17

sorry, I select the wrong database in the Issue. I use a MySQL database. Please change it.

I have also take a look into the logfile and it seems that the function iconv_substr isn't available (I don't know if this is the error)

iconv_substr() [<a href='function.iconv-substr'>function.iconv-substr</a>]: Unknown error (0) - in C:\EasyWAMP\www\testlink_1_9_RC1\lib\functions\common.php - Line 953
(0012113)
asimon (developer)
2010-10-28 09:29

This seems to be an error with your PHP version. Take a look at the comments there: http://de.php.net/manual/en/function.iconv-substr.php [^]
(0012114)
asimon (developer)
2010-10-28 09:38

iconv_substr() is used in common.php on line 1019. That's the only occurrence of the function. Seems like we can replace it by mb_substr().
I tried that and didn't notice any side effects.

KathrinMarkus, can you try if that works for you?
(0012115)
KathrinMarkus (reporter)
2010-10-28 09:40

it works perfectly (thank you :-))
(0012116)
asimon (developer)
2010-10-28 09:56

Thanks for trying!
It's committed to our CVS now and will be in TL 1.9.
(0012527)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-10-28 05:12 KathrinMarkus New Issue
2010-10-28 07:25 Julian Summary Status and Type for requirements are not saved => [MSSQL] Status and Type for requirements are not saved
2010-10-28 07:25 Julian Note Added: 0012109
2010-10-28 09:17 KathrinMarkus Note Added: 0012112
2010-10-28 09:29 asimon Note Added: 0012113
2010-10-28 09:38 asimon Note Added: 0012114
2010-10-28 09:40 KathrinMarkus Note Added: 0012115
2010-10-28 09:56 asimon Note Added: 0012116
2010-10-28 09:57 asimon Status new => resolved
2010-10-28 09:57 asimon Fixed in Version => 1.9 (Prague)
2010-10-28 09:57 asimon Resolution open => fixed
2010-10-28 09:57 asimon Assigned To => asimon
2010-10-28 09:57 Julian Status resolved => assigned
2010-10-28 09:57 Julian Resolution fixed => reopened
2010-10-28 09:58 Julian Database MSSQL => -
2010-10-28 09:58 Julian Summary [MSSQL] Status and Type for requirements are not saved => Status and Type for requirements are not saved
2010-10-28 09:58 Julian Status assigned => resolved
2010-10-28 09:58 Julian Resolution reopened => fixed
2010-11-14 12:07 fman Note Added: 0012527
2010-11-14 12:07 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker