Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003928TestLinkTest Specificationpublic2010-10-22 13:582010-11-14 12:07
ReporterVincent 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version1.9 (Prague) 
Summary0003928: Custom fields are not well displayed
DescriptionWhen you put some custom fields before steps the custom field label is align to step numbers and the value to step actions.
To solve the problem I have just copy the colspan option from the other field for the <td> tag.

Index: gui/templates/testcases/inc_tcbody.tpl
===================================================================
--- gui/templates/testcases/inc_tcbody.tpl (révision 13)
+++ gui/templates/testcases/inc_tcbody.tpl (copie de travail)
@@ -55,7 +55,7 @@
        {* 20090718 - franciscom *}
        {if $inc_tcbody_cf.before_steps_results neq ''}
        <tr>
- <td>
+ <td colspan="{$inc_tcbody_tableColspan}">
     {$inc_tcbody_cf.before_steps_results}
     </td>
        </tr>
Steps To ReproduceCreate a custom field with a long name (“example field”) and with the type textarea
Assign this custom field to a project and change “location” to “Before steps” instead of “standard”
Go to a test case with some steps
Edit the test case and put a long text in the custom field (a text that can’t be displayed in one line)
Now you can see that the custom fields disturb the appearance of the steps
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE / Firefox
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon custom_fields_now.PNG [^] (71,571 bytes) 2010-10-23 16:36


png file icon custom_fields_with_modification.PNG [^] (72,107 bytes) 2010-10-23 16:36

- Relationships

-  Notes
(0012034)
fman (administrator)
2010-10-22 14:17

Please follow this advice:
1. give detailed steps to reproduce always
2. use good subjects Custom fields are not well displayed -> is not good because
seems problem occurs if name is long
(0012058)
Vincent (reporter)
2010-10-23 16:51

Because a picture is is more comprehensive than what I could explain in my poor English, I have post tow picture. The first one show how testlink 1.9 RC1 is working. The custom field made the first column of test step too big and the custom field value didn't take the whole line.
The second one show what the page should be (or something like that).

I hope you understand what I have tried to say and sorry for my English.
(0012059)
Julian (reporter)
2010-10-24 07:22

thank you.

i also added colspan for test case display on execution.
(0012542)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-10-22 13:58 Vincent New Issue
2010-10-22 14:17 fman Note Added: 0012034
2010-10-23 16:36 Vincent File Added: custom_fields_now.PNG
2010-10-23 16:36 Vincent File Added: custom_fields_with_modification.PNG
2010-10-23 16:51 Vincent Note Added: 0012058
2010-10-24 07:04 Julian Assigned To => Julian
2010-10-24 07:04 Julian Status new => assigned
2010-10-24 07:22 Julian Note Added: 0012059
2010-10-24 07:22 Julian Status assigned => resolved
2010-10-24 07:22 Julian Fixed in Version => 1.9 (Prague)
2010-10-24 07:22 Julian Resolution open => fixed
2010-11-14 12:07 fman Note Added: 0012542
2010-11-14 12:07 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker