Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003920TestLinkAPI - XMLRPCpublic2010-10-21 14:002010-11-14 12:07
Reporterkinow 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version1.9 (Prague) 
Summary0003920: xmlrpc api method 'createTestProject' doesn't allow to enable requirements, test priority/automation or inventory
DescriptionThe TL API's createTestProject method doesn't allow to enable requirements, test priority/automation or inventory.

I created a test project in TestLink and the options were serialized as:

O:8:"stdClass":4:{s:19:"requirementsEnabled";i:1;s:19:"testPriorityEnabled";i:1;s:17:"automationEnabled";i:1;s:16:"inventoryEnabled";i:1;}

Then I created another test project using TL API and the options were serialized as:

O:8:"stdClass":3:{s:16:"requirement_mgmt";i:1;s:13:"priority_mgmt";i:1;s:19:"automated_execution";i:1;}

Are requirementsEnabled and requirement_mgmt referring to the same parameter?

I'll start to debug and check how augment the list of parameters and let the user specify more options to the Test Project.
Steps To Reproduce1. Create a project using TestLink API
2. Check Requirements, Priority, Automation and Inventory options
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5>
BrowserFirefox/IE
PHP Version5.3 x86 thread-safe VC 6
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon xmlrpc.class.php [^] (161,805 bytes) 2010-10-21 17:53
zip file icon fix-3920.zip [^] (34,012 bytes) 2010-10-23 09:46

- Relationships
related to 0003916closedfman xmlrpc api method 'getTestCaseCustomFieldDesignValue' is not behaving correctly in TL 1.9 RC1 

-  Notes
(0012020)
kinow (reporter)
2010-10-21 17:56

Check in the xmlrpc.class.php file the functions:
- createTestProject
- _getTestProjectOptions (near the end of the file)
- _bool (end of the file)

I know it has many mistakes in the code, I just wanted to show my idea for the createTestProject method. I believe the attributes of the $options variable were wrong, probably because they changed due to some BUG fix and weren't updated in TL API.

What do you guys think?
(0012021)
kinow (reporter)
2010-10-21 17:57

Uploaded a version of the xmlrpc.class.php with a modified version of createTestProject and two extra methods to show what I was thinking when created this issue. I would like somebody to review this, please.
(0012050)
fman (administrator)
2010-10-23 09:47

Please try attached fix (this solves also related issue 3916), and let us know
(0012052)
kinow (reporter)
2010-10-23 11:54

@fman: It is working! Thanks again! BTW, I figured out what was happening when passing arrays from Java to PHP, it was something really easy, just a BUG in TestLink Java API. I'm fixing this issue, now it's time to annoy Daniel Padilla there and let you guys work here in TL in peace (-: Way to go!
(0012544)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-10-21 14:00 kinow New Issue
2010-10-21 17:53 kinow File Added: xmlrpc.class.php
2010-10-21 17:56 kinow Note Added: 0012020
2010-10-21 17:57 kinow Note Added: 0012021
2010-10-21 17:57 kinow Status new => feedback
2010-10-22 18:55 fman Assigned To => fman
2010-10-22 18:55 fman Status feedback => assigned
2010-10-23 09:46 fman File Added: fix-3920.zip
2010-10-23 09:46 fman Relationship added related to 0003916
2010-10-23 09:47 fman Note Added: 0012050
2010-10-23 09:47 fman Status assigned => feedback
2010-10-23 11:54 kinow Note Added: 0012052
2010-10-23 11:54 kinow Status feedback => assigned
2010-10-23 13:33 fman Status assigned => resolved
2010-10-23 13:33 fman Fixed in Version => 1.9 (Prague)
2010-10-23 13:33 fman Resolution open => fixed
2010-11-14 12:07 fman Note Added: 0012544
2010-11-14 12:07 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker