Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003916TestLinkAPI - XMLRPCpublic2010-10-20 12:502010-11-14 12:07
Reporterkinow 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9 RC 1 
Fixed in Version1.9 (Prague) 
Summary0003916: xmlrpc api method 'getTestCaseCustomFieldDesignValue' is not behaving correctly in TL 1.9 RC1
DescriptionI have some code that was running without errors in TL 1.9-beta6. This code was using TestLink's xmlrpc API to retrive the value of a Custom Field in a Test Case. The method called in this code is getTestCaseCustomFieldDesignValue.

I guess there is some work to be done on the TL API, perhaps because of BUG 3431, that made Custom Fields linked to version instead of directly to an entity (element) id.
Steps To Reproduce1. Install TestLink 1.9RC1
2. Create a test project
3. Create a test suite
4. Create a test case (available for test spec)
5. Create a custom field
6. Assign the custom field
7. Check that the field appeared on the Test Case (created in test step 4) in Test Case specification
8. Write a value for this custom field.
9. Execute the test case and check that the custom field's value appeared in the execution summary correctly.
10. Use xmlrpc method getTestCaseCustomFieldDesignValue, passing the test case id, test project id, custom field name and details as full)
11. 'value' field will be returned as null )-:
Additional Information- I'm using a TestLink 1.9 RC1 fresh installation. It is not being updated from a previous installed TestLink.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5>
BrowserFirefox/IE
PHP Version5.3 x86 thread-safe VC 6
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon xmlrpc.class.php [^] (161,805 bytes) 2010-10-20 17:08
zip file icon fix-3916.zip [^] (33,375 bytes) 2010-10-23 07:59

- Relationships
related to 0003920closedfman xmlrpc api method 'createTestProject' doesn't allow to enable requirements, test priority/automation or inventory 

-  Notes
(0012001)
kinow (reporter)
2010-10-20 13:28

I figured out what is happening, I'll post the source files after I've cleaned them up and removed dev/debug information.
(0012007)
kinow (reporter)
2010-10-20 17:14
edited on: 2010-10-20 17:15

The problem is happening because in the xmlrpc method getTestCaseCustomFieldDesignValue we are not passing the test case version id, required in the testcasemanager after bug 3431.

However, it is also necessary to find out the tcversionid and use it in the query, as the value is linked to the version now, and not with the test case anymore.

I made some modifications in xmlrpc.class.php and testcase.class.php. However testcase.class.php modifications are missing more validation/verification. I believe somebody more experienced with TL development could review it, please. Sorry, I'm still not 100% used to TL source code and components.

Cheers,
B

(0012008)
kinow (reporter)
2010-10-20 17:18

Hi, could somebody please review the code enclosed in this issue and check if it could be a solution for this BUG?
Many thanks, Bruno.
(0012010)
fman (administrator)
2010-10-20 17:38

1. Parameter list can not be changed just augmented -> version number or version id is needed, but tcexternal id can not be removed.
(0012011)
kinow (reporter)
2010-10-20 18:51

True, my mistake. I should had added the other parameter. What do you think is better, version number or version id?
(0012014)
fman (administrator)
2010-10-20 21:19

I've started work on this issue using your code as starting base => I will commit when finished -> I will add version number.
stay tunned
(0012015)
kinow (reporter)
2010-10-20 22:44

Cool, if you need some help, don't hesitate. Thank you very much Francisco.
(0012048)
fman (administrator)
2010-10-23 07:59

please use attached fix, test and let us know
(0012051)
kinow (reporter)
2010-10-23 11:04

@fman It is working! I read the code and it is very clean and neat, also liked checkTestCaseVersionNumberAncestry method. I hadn't think about it (-: Good job. Thank you.
(0012543)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-10-20 12:50 kinow New Issue
2010-10-20 13:28 kinow Note Added: 0012001
2010-10-20 17:08 kinow File Added: xmlrpc.class.php
2010-10-20 17:08 kinow File Added: testcase.class.php
2010-10-20 17:14 kinow Note Added: 0012007
2010-10-20 17:15 kinow Note Edited: 0012007 View Revisions
2010-10-20 17:18 kinow Note Added: 0012008
2010-10-20 17:18 kinow Status new => feedback
2010-10-20 17:28 fman Assigned To => fman
2010-10-20 17:28 fman Status feedback => assigned
2010-10-20 17:38 fman Note Added: 0012010
2010-10-20 18:51 kinow Note Added: 0012011
2010-10-20 21:19 fman Note Added: 0012014
2010-10-20 22:44 kinow Note Added: 0012015
2010-10-23 07:54 fman File Deleted: testcase.class.php
2010-10-23 07:59 fman File Added: fix-3916.zip
2010-10-23 07:59 fman Note Added: 0012048
2010-10-23 07:59 fman Status assigned => feedback
2010-10-23 09:46 fman Relationship added related to 0003920
2010-10-23 11:04 kinow Note Added: 0012051
2010-10-23 11:04 kinow Status feedback => assigned
2010-10-23 13:34 fman Status assigned => resolved
2010-10-23 13:34 fman Fixed in Version => 1.9 (Prague)
2010-10-23 13:34 fman Resolution open => fixed
2010-11-14 12:07 fman Note Added: 0012543
2010-11-14 12:07 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker