Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003893TestLinkReportspublic2010-10-13 19:502010-11-14 12:07
Reportermedienwolf 
Assigned ToJulian 
PrioritynoneSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformallOSallOS Versionall
Product Version1.9 Beta 6 
Fixed in Version1.9 (Prague) 
Summary0003893: Overview Metric Report for all Test Plans in a project
DescriptionCurrently testlink provides statistics for each test plan separately, however there is no "overview statistics" that spans all test plans contained in a project.

This feature request asks for a metrics report, that lists the following statistics:(similar to build status/top level suite report, just for many test plans)

Testplan Name | Build TC Total | Not Run [%] | Passed [%]| Failed [%] | Blocked [%] | Completed [%]
Testplan 1 SAT R1 459 324 70.59 135 29.41 0 0.00 0 0.00 29.41
|
Testplan 2 ....
Testplan 3 ....
Testplan N ....

TOTAL ......................

Benefit: this would be a very quick overview (dashboard) about the complete project status.
Right now, this can be achieved by exporting general test plan metrics.

If the feature cannot be implemented, is there the possiblity that you could provide the related SQL query and we could generate a script that can produce this output.

Thansk
Hans-Joerg
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0011885)
Julian (reporter)
2010-10-13 19:57

how about you find the solution and contribute ? we wont support custom solutions.

Provide us with examples based on current output of metrics dashboard and/or general test plan metrics.
please consider testplans with and without platforms for your analysis.
(0011886)
difool (reporter)
2010-10-13 21:23

i'm currently finishing to do this report, even more complete ;)

As soon as it's finished i'll will post my contribution like my other report contribution ( http://mantis.testlink.org/view.php?id=3870 [^] ) ..

But when nobody (incl. dev) give feedback ...
(0011887)
medienwolf (reporter)
2010-10-13 21:48

Difool, i just checked out your link, this looks pretty good.
Too bad that we are not using mantis, but redmine :-)

Let everyone know when you are finished, this will be really useful.
(0011888)
difool (reporter)
2010-10-13 22:08

You can adjust for redmine, i think this is quite simple, juste to know the field name is necessary.

Tomorrow (it's currently 00h10 here) i'll post my test project synthesis report so you won't wait too long.
(0011891)
fman (administrator)
2010-10-14 08:47

@diftool:
>> But when nobody (incl. dev) give feedback ...
absolutely bad attitude.
(0011893)
difool (reporter)
2010-10-14 09:38

@fman: that was to make you react ;) but ok it was bad ;) my apologizes ....
(0011895)
amitkhullar (reporter)
2010-10-14 10:36

could you please attach the code if done.
(0011896)
Julian (reporter)
2010-10-14 10:48

i am currently working on extending metrics dashboard.
difool, if you did not start work yet please wait for my changes and let me know if they are sufficient.
(0011897)
difool (reporter)
2010-10-14 10:56

i've finished my work :)
(0011903)
difool (reporter)
2010-10-14 14:25

You could find my trial into http://mantis.testlink.org/view.php?id=3896 [^]
(0011908)
Julian (reporter)
2010-10-14 18:44

Code on CVS.
Probably not in final state. Take a look and let me know.
Main Page -> Metrics Dashboard has been extended

added config parameter $tlCfg->metricsDashboardReport->show_test_plan_status_details which allows to display status details for each test plan on group
(0011909)
medienwolf (reporter)
2010-10-14 19:10

Difool and Julian - great from you to include this for everyone! Thanks a lot.

Unfortunately i am not (yet) a testlink developer, so i'm not sure in which files to do the modifications to adapt the code to e.g. redmine.
Can you be a bit more specific on the location of the file/variables to consider? I coulnd't detect anything specific to a db in your code except
the code to fetch the testplans in bbiresultsGeneral.php.

From a functionality point of view, i think it would also be helpful to see in the metric, whether the test cases passed/failed or blocked. Sometimes the test case can pass, but still have minor/medium bugs assigned to it. And also, it is great to see which bugs actually block the test case.

Do you see a chance to add this field as well?
E.g. #test cases run #test cases failed #test cases blocked #test cases passed?
(0011910)
difool (reporter)
2010-10-14 20:09
edited on: 2010-10-14 20:10

About the offical code (code on CVS from metrics dashboard) no need to adapt something to Redmine.

About the global project report (mine), i'll wait that Julian (or other) take a look at my work and tell me if spending more time on it is valuable or not.

About the bug report (mine), same thing, wait that people say if interesting or not because it's quite a lot of work. If so then i think that adding the tc status (pass/failed/etc..) for each tc with a bug would be integrated.
For this report, you must adapt the int_redmine.php into lib\bugtracking to add the severity field name into the SQL query, use my int_mantis.php as canvas.

(0011941)
Julian (reporter)
2010-10-17 16:36

i think metrics dashboard offers the required information now.
this is why i will set this issue to resolved.

information that was added to metrics dashboard:
- progress for whole project (progress bars for overall progress, % failed, % not run, %blocked, +(% custom defined states))
- overall progress for a whole test plan (useful if platforms are used)
(0012557)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2010-10-13 19:50 medienwolf New Issue
2010-10-13 19:57 Julian Note Added: 0011885
2010-10-13 21:23 difool Note Added: 0011886
2010-10-13 21:48 medienwolf Note Added: 0011887
2010-10-13 22:08 difool Note Added: 0011888
2010-10-14 08:47 fman Note Added: 0011891
2010-10-14 08:48 fman Priority high => none
2010-10-14 08:48 fman Summary Provide One Overview Metric Report for all Test Plans in a project => Overview Metric Report for all Test Plans in a project
2010-10-14 09:38 difool Note Added: 0011893
2010-10-14 10:36 amitkhullar Note Added: 0011895
2010-10-14 10:48 Julian Note Added: 0011896
2010-10-14 10:56 difool Note Added: 0011897
2010-10-14 14:25 difool Note Added: 0011903
2010-10-14 18:44 Julian Note Added: 0011908
2010-10-14 19:10 medienwolf Note Added: 0011909
2010-10-14 20:09 difool Note Added: 0011910
2010-10-14 20:10 difool Note Edited: 0011910 View Revisions
2010-10-17 16:36 Julian Note Added: 0011941
2010-10-17 16:36 Julian Status new => resolved
2010-10-17 16:36 Julian Fixed in Version => 1.9 (Prague)
2010-10-17 16:36 Julian Resolution open => fixed
2010-10-17 16:36 Julian Assigned To => Julian
2010-11-14 12:07 fman Note Added: 0012557
2010-11-14 12:07 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker