Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003866TestLinkReportspublic2010-10-07 08:402013-05-30 19:48
ReporterKathrinMarkus 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versiontestlink_1_9_rc1-qa-20100926 
Fixed in Version1.9 RC 1 
Summary0003866: Analyse Requirements: requirements are not listed in Analyse Page
Descriptionnormally the requirements should be listed in the page under the specific part (covered, uncovered, not testable). in the current release candidate there always written "None" (NOK)

locally I have solved this issue by comment out line
$getFilters = array('status' => VALID_REQ);
in function function get_coverage($id)
Steps To Reproduceprerequisite:
- testlink database with requirements included
- requirements linked to different testcases

open testlink page
in main tab select Requirement Specification
select any requirement specification folder
in the content page click button "Analyse"
=> now there is given an overview about the requirements (OK), but only the metric is visible, not the detailed list of requirements(NOK)
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
BrowserFirefox 3.6.10, Internet Explorer 8
PHP Version5.2.0
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon debug_error [^] (13,971 bytes) 2010-10-07 12:57 [Show Content]

- Relationships

-  Notes
(0011660)
Julian (reporter)
2010-10-07 10:08

do we need this report anymore ?

i think this one can be replaced by
"Test Reports -> Requirement based report"

-> remove analyse button and old files of feature ?
(0011661)
Julian (reporter)
2010-10-07 10:08

Reminder sent to: asimon, fman

please check this issue
(0011663)
Julian (reporter)
2010-10-07 12:32

let us know what has been changed
(0011664)
asimon (developer)
2010-10-07 12:36

I removed the button for this functionality from req spec buttons and also the two old files (.php and template) which were not needed anymore.
(0011665)
KathrinMarkus (reporter)
2010-10-07 12:42

I don't think you should remove this page, because it is very nice and helpful.
(0011666)
Julian (reporter)
2010-10-07 12:43

and very outdated

what is the problem with requirement based report ?
(0011667)
KathrinMarkus (reporter)
2010-10-07 12:56

Requirement based report:
- does not work with IE 8
- does not really gives an overview about covered testcases, because in my case all requirements are not covered (Mozilla Firfox)
- an debug error is given if I open the report (see attachment)
(0011854)
asimon (developer)
2010-10-11 08:42

Please test requirement based report again with the latest release from Sourceforge (RC1) and tell us if it works now.
(0014902)
Julian (reporter)
2011-05-23 09:40

no more user action -> resolved

- Issue History
Date Modified Username Field Change
2010-10-07 08:40 KathrinMarkus New Issue
2010-10-07 10:08 Julian Note Added: 0011660
2010-10-07 10:08 Julian Note Added: 0011661
2010-10-07 12:18 asimon Status new => resolved
2010-10-07 12:18 asimon Fixed in Version => 1.9 RC 1
2010-10-07 12:18 asimon Resolution open => fixed
2010-10-07 12:18 asimon Assigned To => asimon
2010-10-07 12:32 Julian Note Added: 0011663
2010-10-07 12:32 Julian Status resolved => assigned
2010-10-07 12:32 Julian Resolution fixed => reopened
2010-10-07 12:36 asimon Note Added: 0011664
2010-10-07 12:42 KathrinMarkus Note Added: 0011665
2010-10-07 12:43 Julian Note Added: 0011666
2010-10-07 12:56 KathrinMarkus Note Added: 0011667
2010-10-07 12:57 KathrinMarkus File Added: debug_error
2010-10-11 08:42 asimon Note Added: 0011854
2011-05-23 09:40 Julian Note Added: 0014902
2011-05-23 09:40 Julian Status assigned => resolved
2011-05-23 09:40 Julian Resolution reopened => fixed
2013-05-30 19:48 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker