Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003852TestLinkRequirement Managementpublic2010-10-05 05:152010-10-09 08:00
Reporterskilletaudio 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows VistaOS Version
Product Versiontestlink_1_9_rc1-qa-20100926 
Fixed in Version1.9 RC 1 
Summary0003852: Filter requirements by status resets on apply
DescriptionTest case TL-252

When applying a filter using 'status' of requirement, the status dropdown resets to 'Any' without the desired filter being applied.
Steps To ReproduceCreate some requirements.
Set filter for 'status' and click 'apply'.
TagsNo tags attached.
Database (MySQL,Postgres,etc)postgres
BrowserFF 3
PHP Version5.2.1
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0011628)
amitkhullar (reporter)
2010-10-05 08:44

Reminder sent to: asimon

Hi Andreas,

this error is due to the filter not working due to the code @ line 316 in tlRequirementFilterControl.class.php

        if (!($selection) || $this->args->reset_filters || $selection == self::ANY
        || (is_array($selection) && in_array(self::ANY, $selection)))
        { print_r("Yes");
            $selection = null;
        } else {
            $this->do_filtering = true;
        }

The code always goes for $selection = null due to a failing condition ->
(is_array($selection) && in_array(self::ANY, $selection))

Can you analyze why was this added ?
(0011701)
fman (administrator)
2010-10-09 08:00

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2010-10-05 05:15 skilletaudio New Issue
2010-10-05 08:44 amitkhullar Note Added: 0011628
2010-10-05 13:25 asimon Assigned To => asimon
2010-10-05 13:25 asimon Status new => assigned
2010-10-05 13:58 asimon Status assigned => resolved
2010-10-05 13:58 asimon Fixed in Version => 1.9 RC 1
2010-10-05 13:58 asimon Resolution open => fixed
2010-10-09 08:00 fman Note Added: 0011701
2010-10-09 08:00 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker